This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Update IPC-SysV to CPAN version 2.04
[perl5.git] / cpan / IPC-SysV / t / podcov.t
1 ################################################################################
2 #
3 #  Version 2.x, Copyright (C) 2007-2013, Marcus Holland-Moritz <mhx@cpan.org>.
4 #  Version 1.x, Copyright (C) 1999, Graham Barr <gbarr@pobox.com>.
5 #
6 #  This program is free software; you can redistribute it and/or
7 #  modify it under the same terms as Perl itself.
8 #
9 ################################################################################
10
11 BEGIN {
12   if ($ENV{'PERL_CORE'}) {
13     chdir 't' if -d 't';
14     @INC = '../lib' if -d '../lib' && -d '../ext';
15   }
16
17   require Test::More; import Test::More;
18   require Config; import Config;
19
20   if ($ENV{'PERL_CORE'} && $Config{'extensions'} !~ m[\bIPC/SysV\b]) {
21     plan(skip_all => 'IPC::SysV was not built');
22   }
23 }
24
25 use strict;
26
27 my @modules = qw( IPC::SysV IPC::Msg IPC::Semaphore IPC::SharedMem );
28
29 eval 'use Pod::Coverage 0.10';
30 plan skip_all => "testing pod coverage requires Pod::Coverage 0.10" if $@;
31
32 eval 'use Test::Pod::Coverage 1.08';
33 plan skip_all => "testing pod coverage requires Test::Pod::Coverage 1.08" if $@;
34
35 plan tests => scalar @modules;
36
37 my $mod = shift @modules;
38 pod_coverage_ok($mod, { trustme => [qw( dl_load_flags )] }, "$mod is covered");
39
40 for my $mod (@modules) {
41   pod_coverage_ok($mod, "$mod is covered");
42 }