This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade to version.pm 0.60
[perl5.git] / lib / version.t
1 #! /usr/local/perl -w
2 # Before `make install' is performed this script should be runnable with
3 # `make test'. After `make install' it should work as `perl test.pl'
4
5 #########################
6
7 use Test::More qw(no_plan);
8 require Test::Harness;
9 no warnings 'once';
10 *Verbose = \$Test::Harness::Verbose;
11
12 diag "Tests with base class" unless $ENV{PERL_CORE};
13
14 BEGIN {
15     use_ok("version", 0.50); # If we made it this far, we are ok.
16 }
17
18 BaseTests("version");
19
20 diag "Tests with empty derived class" unless $ENV{PERL_CORE};
21
22 package version::Empty;
23 use base version;
24 $VERSION = 0.01;
25 no warnings 'redefine';
26 *::qv = sub { return bless version::qv(shift), __PACKAGE__; };
27
28 package version::Bad;
29 use base version;
30 sub new { my($self,$n)=@_;  bless \$n, $self }
31
32 package main;
33 my $testobj = version::Empty->new(1.002_003);
34 isa_ok( $testobj, "version::Empty" );
35 ok( $testobj->numify == 1.002003, "Numified correctly" );
36 ok( $testobj->stringify eq "1.002003", "Stringified correctly" );
37 ok( $testobj->normal eq "v1.2.3", "Normalified correctly" );
38
39 my $verobj = version->new("1.2.4");
40 ok( $verobj > $testobj, "Comparison vs parent class" );
41 ok( $verobj gt $testobj, "Comparison vs parent class" );
42 BaseTests("version::Empty");
43
44 diag "tests with bad subclass" unless $ENV{PERL_CORE};
45 $testobj = version::Bad->new(1.002_003);
46 isa_ok( $testobj, "version::Bad" );
47 eval { my $string = $testobj->numify };
48 like($@, qr/Invalid version object/,
49     "Bad subclass numify");
50 eval { my $string = $testobj->normal };
51 like($@, qr/Invalid version object/,
52     "Bad subclass normal");
53 eval { my $string = $testobj->stringify };
54 like($@, qr/Invalid version object/,
55     "Bad subclass stringify");
56 eval { my $test = $testobj > 1.0 };
57 like($@, qr/Invalid version object/,
58     "Bad subclass vcmp");
59
60 sub BaseTests {
61
62         my ($CLASS, $no_qv) = @_;
63         
64         # Insert your test code below, the Test module is use()ed here so read
65         # its man page ( perldoc Test ) for help writing this test script.
66         
67         # Test bare number processing
68         diag "tests with bare numbers" if $Verbose;
69         $version = $CLASS->new(5.005_03);
70         is ( "$version" , "5.005030" , '5.005_03 eq 5.5.30' );
71         $version = $CLASS->new(1.23);
72         is ( "$version" , "1.230" , '1.23 eq "1.230"' );
73         
74         # Test quoted number processing
75         diag "tests with quoted numbers" if $Verbose;
76         $version = $CLASS->new("5.005_03");
77         is ( "$version" , "5.005_030" , '"5.005_03" eq "5.005_030"' );
78         $version = $CLASS->new("v1.23");
79         is ( "$version" , "v1.23.0" , '"v1.23" eq "v1.23.0"' );
80         
81         # Test stringify operator
82         diag "tests with stringify" if $Verbose;
83         $version = $CLASS->new("5.005");
84         is ( "$version" , "5.005" , '5.005 eq "5.005"' );
85         $version = $CLASS->new("5.006.001");
86         is ( "$version" , "v5.6.1" , '5.006.001 eq v5.6.1' );
87         $version = $CLASS->new("1.2.3_4");
88         is ( "$version" , "v1.2.3_4" , 'alpha version 1.2.3_4 eq v1.2.3_4' );
89         
90         # test illegal formats
91         diag "test illegal formats" if $Verbose;
92         eval {my $version = $CLASS->new("1.2_3_4")};
93         like($@, qr/multiple underscores/,
94             "Invalid version format (multiple underscores)");
95         
96         eval {my $version = $CLASS->new("1.2_3.4")};
97         like($@, qr/underscores before decimal/,
98             "Invalid version format (underscores before decimal)");
99         
100         eval {my $version = $CLASS->new("1_2")};
101         like($@, qr/alpha without decimal/,
102             "Invalid version format (alpha without decimal)");
103
104         # for this first test, just upgrade the warn() to die()
105         eval {
106             local $SIG{__WARN__} = sub { die $_[0] };
107             $version = $CLASS->new("1.2b3");
108         };
109         my $warnregex = "Version string '.+' contains invalid data; ".
110                 "ignoring: '.+'";
111
112         like($@, qr/$warnregex/,
113             "Version string contains invalid data; ignoring");
114
115         # from here on out capture the warning and test independently
116         my $warning;
117         local $SIG{__WARN__} = sub { $warning = $_[0] };
118         $version = $CLASS->new("99 and 44/100 pure");
119
120         like($warning, qr/$warnregex/,
121             "Version string contains invalid data; ignoring");
122         ok ("$version" eq "99.000", '$version eq "99.000"');
123         ok ($version->numify == 99.0, '$version->numify == 99.0');
124         ok ($version->normal eq "v99.0.0", '$version->normal eq v99.0.0');
125         
126         $version = $CLASS->new("something");
127         like($warning, qr/$warnregex/,
128             "Version string contains invalid data; ignoring");
129         ok (defined $version, 'defined $version');
130         
131         # reset the test object to something reasonable
132         $version = $CLASS->new("1.2.3");
133         
134         # Test boolean operator
135         ok ($version, 'boolean');
136         
137         # Test class membership
138         isa_ok ( $version, $CLASS );
139         
140         # Test comparison operators with self
141         diag "tests with self" if $Verbose;
142         ok ( $version eq $version, '$version eq $version' );
143         is ( $version cmp $version, 0, '$version cmp $version == 0' );
144         ok ( $version == $version, '$version == $version' );
145         
146         # test first with non-object
147         $version = $CLASS->new("5.006.001");
148         $new_version = "5.8.0";
149         diag "tests with non-objects" if $Verbose;
150         ok ( $version ne $new_version, '$version ne $new_version' );
151         ok ( $version lt $new_version, '$version lt $new_version' );
152         ok ( $new_version gt $version, '$new_version gt $version' );
153         ok ( ref(\$new_version) eq 'SCALAR', 'no auto-upgrade');
154         $new_version = "$version";
155         ok ( $version eq $new_version, '$version eq $new_version' );
156         ok ( $new_version eq $version, '$new_version eq $version' );
157         
158         # now test with existing object
159         $new_version = $CLASS->new("5.8.0");
160         diag "tests with objects" if $Verbose;
161         ok ( $version ne $new_version, '$version ne $new_version' );
162         ok ( $version lt $new_version, '$version lt $new_version' );
163         ok ( $new_version gt $version, '$new_version gt $version' );
164         $new_version = $CLASS->new("$version");
165         ok ( $version eq $new_version, '$version eq $new_version' );
166         
167         # Test Numeric Comparison operators
168         # test first with non-object
169         $new_version = "5.8.0";
170         diag "numeric tests with non-objects" if $Verbose;
171         ok ( $version == $version, '$version == $version' );
172         ok ( $version < $new_version, '$version < $new_version' );
173         ok ( $new_version > $version, '$new_version > $version' );
174         ok ( $version != $new_version, '$version != $new_version' );
175         
176         # now test with existing object
177         $new_version = $CLASS->new($new_version);
178         diag "numeric tests with objects" if $Verbose;
179         ok ( $version < $new_version, '$version < $new_version' );
180         ok ( $new_version > $version, '$new_version > $version' );
181         ok ( $version != $new_version, '$version != $new_version' );
182         
183         # now test with actual numbers
184         diag "numeric tests with numbers" if $Verbose;
185         ok ( $version->numify() == 5.006001, '$version->numify() == 5.006001' );
186         ok ( $version->numify() <= 5.006001, '$version->numify() <= 5.006001' );
187         ok ( $version->numify() < 5.008, '$version->numify() < 5.008' );
188         #ok ( $version->numify() > v5.005_02, '$version->numify() > 5.005_02' );
189         
190         # test with long decimals
191         diag "Tests with extended decimal versions" if $Verbose;
192         $version = $CLASS->new(1.002003);
193         ok ( $version eq "1.2.3", '$version eq "1.2.3"');
194         ok ( $version->numify == 1.002003, '$version->numify == 1.002003');
195         $version = $CLASS->new("2002.09.30.1");
196         ok ( $version eq "2002.9.30.1",'$version eq 2002.9.30.1');
197         ok ( $version->numify == 2002.009030001,
198             '$version->numify == 2002.009030001');
199         
200         # now test with alpha version form with string
201         $version = $CLASS->new("1.2.3");
202         $new_version = "1.2.3_4";
203         diag "tests with alpha-style non-objects" if $Verbose;
204         ok ( $version lt $new_version, '$version lt $new_version' );
205         ok ( $new_version gt $version, '$new_version gt $version' );
206         ok ( $version ne $new_version, '$version ne $new_version' );
207         
208         $version = $CLASS->new("1.2.4");
209         diag "numeric tests with alpha-style non-objects"
210             if $Verbose;
211         ok ( $version > $new_version, '$version > $new_version' );
212         ok ( $new_version < $version, '$new_version < $version' );
213         ok ( $version != $new_version, '$version != $new_version' );
214         
215         # now test with alpha version form with object
216         $version = $CLASS->new("1.2.3");
217         $new_version = $CLASS->new("1.2.3_4");
218         diag "tests with alpha-style objects" if $Verbose;
219         ok ( $version < $new_version, '$version < $new_version' );
220         ok ( $new_version > $version, '$new_version > $version' );
221         ok ( $version != $new_version, '$version != $new_version' );
222         ok ( !$version->is_alpha, '!$version->is_alpha');
223         ok ( $new_version->is_alpha, '$new_version->is_alpha');
224         
225         $version = $CLASS->new("1.2.4");
226         diag "tests with alpha-style objects" if $Verbose;
227         ok ( $version > $new_version, '$version > $new_version' );
228         ok ( $new_version < $version, '$new_version < $version' );
229         ok ( $version != $new_version, '$version != $new_version' );
230         
231         $version = $CLASS->new("1.2.3.4");
232         $new_version = $CLASS->new("1.2.3_4");
233         diag "tests with alpha-style objects with same subversion"
234             if $Verbose;
235         ok ( $version > $new_version, '$version > $new_version' );
236         ok ( $new_version < $version, '$new_version < $version' );
237         ok ( $version != $new_version, '$version != $new_version' );
238         
239         diag "test implicit [in]equality" if $Verbose;
240         $version = $CLASS->new("v1.2.3");
241         $new_version = $CLASS->new("1.2.3.0");
242         ok ( $version == $new_version, '$version == $new_version' );
243         $new_version = $CLASS->new("1.2.3_0");
244         ok ( $version == $new_version, '$version == $new_version' );
245         $new_version = $CLASS->new("1.2.3.1");
246         ok ( $version < $new_version, '$version < $new_version' );
247         $new_version = $CLASS->new("1.2.3_1");
248         ok ( $version < $new_version, '$version < $new_version' );
249         $new_version = $CLASS->new("1.1.999");
250         ok ( $version > $new_version, '$version > $new_version' );
251         
252         # that which is not expressly permitted is forbidden
253         diag "forbidden operations" if $Verbose;
254         ok ( !eval { ++$version }, "noop ++" );
255         ok ( !eval { --$version }, "noop --" );
256         ok ( !eval { $version/1 }, "noop /" );
257         ok ( !eval { $version*3 }, "noop *" );
258         ok ( !eval { abs($version) }, "noop abs" );
259
260 SKIP: {
261         skip "version require'd instead of use'd, cannot test qv", 3
262             if defined $no_qv;
263         # test the qv() sub
264         diag "testing qv" if $Verbose;
265         $version = qv("1.2");
266         cmp_ok ( $version, "eq", "v1.2.0", 'qv("1.2") eq "1.2.0"' );
267         $version = qv(1.2);
268         cmp_ok ( $version, "eq", "v1.2.0", 'qv(1.2) eq "1.2.0"' );
269         isa_ok( qv('5.008'), $CLASS );
270 }
271
272         # test creation from existing version object
273         diag "create new from existing version" if $Verbose;
274         ok (eval {$new_version = $CLASS->new($version)},
275                 "new from existing object");
276         ok ($new_version == $version, "class->new($version) identical");
277         $new_version = $version->new();
278         isa_ok ($new_version, $CLASS );
279         is ($new_version, "0.000", "version->new() doesn't clone");
280         $new_version = $version->new("1.2.3");
281         is ($new_version, "v1.2.3" , '$version->new("1.2.3") works too');
282
283         # test the CVS revision mode
284         diag "testing CVS Revision" if $Verbose;
285         $version = new $CLASS qw$Revision: 1.2$;
286         ok ( $version eq "1.2.0", 'qw$Revision: 1.2$ eq 1.2.0' );
287         $version = new $CLASS qw$Revision: 1.2.3.4$;
288         ok ( $version eq "1.2.3.4", 'qw$Revision: 1.2.3.4$ eq 1.2.3.4' );
289         
290         # test the CPAN style reduced significant digit form
291         diag "testing CPAN-style versions" if $Verbose;
292         $version = $CLASS->new("1.23_01");
293         is ( "$version" , "1.23_0100", "CPAN-style alpha version" );
294         ok ( $version > 1.23, "1.23_01 > 1.23");
295         ok ( $version < 1.24, "1.23_01 < 1.24");
296
297         # test reformed UNIVERSAL::VERSION
298         diag "Replacement UNIVERSAL::VERSION tests" if $Verbose;
299         
300         # we know this file is here since we require it ourselves
301         $version = $Test::More::VERSION;
302         eval "use Test::More $version";
303         unlike($@, qr/Test::More version $version/,
304                 'Replacement eval works with exact version');
305         
306         # test as class method
307         $new_version = Test::More->VERSION;
308         cmp_ok($new_version,'cmp',$version, "Called as class method");
309
310         # this should fail even with old UNIVERSAL::VERSION
311         $version = $Test::More::VERSION+0.01;
312         eval "use Test::More $version";
313         like($@, qr/Test::More version $version/,
314                 'Replacement eval works with incremented version');
315         
316         $version =~ s/\.0$//; #convert to string and remove trailing '.0'
317         chop($version); # shorten by 1 digit, should still succeed
318         eval "use Test::More $version";
319         unlike($@, qr/Test::More version $version/,
320                 'Replacement eval works with single digit');
321         
322         $version += 0.1; # this would fail with old UNIVERSAL::VERSION
323         eval "use Test::More $version";
324         like($@, qr/Test::More version $version/,
325                 'Replacement eval works with incremented digit');
326         
327         { # dummy up some variously broken modules for testing
328             open F, ">xxx.pm" or die "Cannot open xxx.pm: $!\n";
329             print F "1;\n";
330             close F;
331             my $error_regex;
332             if ( $] < 5.008 ) {
333                 $error_regex = 'xxx does not define \$xxx::VERSION';
334             }
335             else {
336                 $error_regex = 'xxx defines neither package nor VERSION';
337             }
338
339             eval "use lib '.'; use xxx 3;";
340             like ($@, qr/$error_regex/,
341                 'Replacement handles modules without package or VERSION'); 
342             eval "use lib '.'; use xxx; $version = xxx->VERSION";
343             unlike ($@, qr/$error_regex/,
344                 'Replacement handles modules without package or VERSION'); 
345             is ($versiona, undef, "Called as class method");
346             unlink 'xxx.pm';
347         }
348     
349         { # dummy up some variously broken modules for testing
350             open F, ">yyy.pm" or die "Cannot open yyy.pm: $!\n";
351             print F "package yyy;\n#look ma no VERSION\n1;\n";
352             close F;
353             eval "use lib '.'; use yyy 3;";
354             like ($@, qr/^yyy does not define \$yyy::VERSION/,
355                 'Replacement handles modules without VERSION'); 
356             eval "use lib '.'; use yyy; print yyy->VERSION";
357             unlike ($@, qr/^yyy does not define \$yyy::VERSION/,
358                 'Replacement handles modules without VERSION'); 
359             unlink 'yyy.pm';
360         }
361
362         { # dummy up some variously broken modules for testing
363             open F, ">zzz.pm" or die "Cannot open zzz.pm: $!\n";
364             print F "package zzz;\n\@VERSION = ();\n1;\n";
365             close F;
366             eval "use lib '.'; use zzz 3;";
367             like ($@, qr/^zzz does not define \$zzz::VERSION/,
368                 'Replacement handles modules without VERSION'); 
369             eval "use lib '.'; use zzz; print zzz->VERSION";
370             unlike ($@, qr/^zzz does not define \$zzz::VERSION/,
371                 'Replacement handles modules without VERSION'); 
372             unlink 'zzz.pm';
373         }
374
375 SKIP:   {
376             skip 'Cannot test bare v-strings with Perl < 5.8.1', 4
377                     if $] < 5.008_001; 
378             diag "Tests with v-strings" if $Verbose;
379             $version = $CLASS->new(1.2.3);
380             ok("$version" eq "v1.2.3", '"$version" eq 1.2.3');
381             $version = $CLASS->new(1.0.0);
382             $new_version = $CLASS->new(1);
383             ok($version == $new_version, '$version == $new_version');
384             ok($version eq $new_version, '$version eq $new_version');
385             skip "version require'd instead of use'd, cannot test qv", 1
386                 if defined $no_qv;
387             $version = qv(1.2.3);
388             ok("$version" eq "v1.2.3", 'v-string initialized qv()');
389         }
390
391         diag "Tests with real-world (malformed) data" if $Verbose;
392
393         # trailing zero testing (reported by Andreas Koenig).
394         $version = $CLASS->new("1");
395         ok($version->numify eq "1.000", "trailing zeros preserved");
396         $version = $CLASS->new("1.0");
397         ok($version->numify eq "1.000", "trailing zeros preserved");
398         $version = $CLASS->new("1.0.0");
399         ok($version->numify eq "1.000000", "trailing zeros preserved");
400         $version = $CLASS->new("1.0.0.0");
401         ok($version->numify eq "1.000000000", "trailing zeros preserved");
402         
403         # leading zero testing (reported by Andreas Koenig).
404         $version = $CLASS->new(".7");
405         ok($version->numify eq "0.700", "leading zero inferred");
406
407         # leading space testing (reported by Andreas Koenig).
408         $version = $CLASS->new(" 1.7");
409         ok($version->numify eq "1.700", "leading space ignored");
410
411 SKIP:   {
412
413             # dummy up a legal module for testing RT#19017
414             open F, ">www.pm" or die "Cannot open www.pm: $!\n";
415             print F <<"EOF";
416 package www;
417 use version; \$VERSION = qv('0.0.4');
418 1;
419 EOF
420             close F;
421
422             eval "use lib '.'; use www 0.000008;";
423             like ($@, qr/^www version 0.000008 \(v0.0.8\) required/,
424                 "Make sure very small versions don't freak"); 
425             eval "use lib '.'; use www 1;";
426             like ($@, qr/^www version 1.000 \(v1.0.0\) required/,
427                 "Comparing vs. version with no decimal"); 
428             eval "use lib '.'; use www 1.;";
429             like ($@, qr/^www version 1.000 \(v1.0.0\) required/,
430                 "Comparing "); 
431
432             skip 'Cannot "use" extended versions with Perl < 5.6.2', 1
433                 if $] < 5.006_002;
434             eval "use lib '.'; use www 0.0.8;";
435             like ($@, qr/^www version 0.000008 \(v0.0.8\) required/,
436                 "Make sure very small versions don't freak"); 
437
438             unlink 'www.pm';
439         }
440 }
441
442 1;