This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade to DB_File 1.838 from CPAN.
[perl5.git] / cpan / Scalar-List-Utils / Makefile.PL
1 # -*- perl -*-
2 BEGIN { require 5.006; }
3 use strict;
4 use warnings;
5 use Config;
6 use File::Spec;
7 use ExtUtils::MakeMaker;
8 my $PERL_CORE = grep { $_ eq 'PERL_CORE=1' } @ARGV;
9
10 WriteMakefile(
11   NAME         => q[List::Util],
12   ABSTRACT     => q[Common Scalar and List utility subroutines],
13   AUTHOR       => q[Graham Barr <gbarr@cpan.org>],
14   DEFINE       => q[-DPERL_EXT],
15   DISTNAME     => q[Scalar-List-Utils],
16   VERSION_FROM => 'lib/List/Util.pm',
17
18   # We go through the ListUtil.xs trickery to foil platforms
19   # that have the feature combination of
20   # (1) static builds
21   # (2) allowing only one object by the same name in the static library
22   # (3) the object name matching being case-blind
23   # This means that we can't have the top-level util.o
24   # and the extension-level Util.o in the same build.
25   # One such platform is the POSIX-BC BS2000 EBCDIC mainframe platform.
26   XS     => {'ListUtil.xs' => 'ListUtil.c'},
27   OBJECT => 'ListUtil$(OBJ_EXT)',
28   ( $PERL_CORE
29     ? ()
30     : (
31       INSTALLDIRS => ($] < 5.011 ? q[perl] : q[site]),
32       PREREQ_PM   => {'Test::More' => 0,},
33       (eval { ExtUtils::MakeMaker->VERSION(6.31) } ? (LICENSE => 'perl') : ()),
34       ( eval { ExtUtils::MakeMaker->VERSION(6.46) } ? (
35           META_MERGE => {
36             resources => {    ##
37               repository => 'https://github.com/Scalar-List-Utils/Scalar-List-Utils',
38             },
39           }
40           )
41         : ()
42       ),
43     )
44   ),
45 );
46