This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
In HP-UX 10.X usethreads only if the required files are present.
[perl5.git] / hints / hpux.sh
1 #! /bin/sh
2
3 # hints/hpux.sh
4 # Perl Configure hints file for Hewlett-Packard's HP-UX 9.x and 10.x
5 # (Hopefully, 7.x through 11.x.)
6 #
7 # This file is based on hints/hpux_9.sh, Perl Configure hints file for
8 # Hewlett Packard HP-UX 9.x
9 #
10 # Use Configure -Dcc=gcc to use gcc.
11 #
12 # From: Jeff Okamoto <okamoto@corp.hp.com>
13 # and
14 # hints/hpux_10.sh, Perl Configure hints file for Hewlett Packard HP-UX 10.x
15 # From: Giles Lean <giles@nemeton.com.au>
16 # and
17 # Use #define CPU_* instead of comments for >= 10.x.
18 # Support PA1.2 under 10.x.
19 # Distinguish between PA2.0, PA2.1, etc.
20 # Distinguish between MC68020, MC68030, MC68040
21 # Don't assume every OS != 10 is < 10, (e.g., 11).
22 # From: Chuck Phillips <cdp@fc.hp.com>
23 # HP-UX 10 pthreads hints: Matthew T Harden <mthard@mthard1.monsanto.com>
24
25 # This version: August 15, 1997
26 # Current maintainer: Jeff Okamoto <okamoto@corp.hp.com>
27
28 #--------------------------------------------------------------------
29 # Use Configure -Dcc=gcc to use gcc.
30 # Use Configure -Dprefix=/usr/local to install in /usr/local.
31 #
32 # You may have dynamic loading problems if the environment variable
33 # LDOPTS='-a archive'.  Under >= 10.x, you can instead LDOPTS='-a
34 # archive_shared' to prefer archive libraries without requiring them.
35 # Regardless of HPUX release, in the "libs" variable or the ext.libs
36 # file, you can always give explicit path names to archive libraries
37 # that may not exist on the target machine.  E.g., /usr/lib/libndbm.a
38 # instead of -lndbm.  See also note below on ndbm.
39 #
40 # ALSO, bear in mind that gdbm and Berkely DB contain incompatible
41 # replacements for ndbm (and dbm) routines.  If you want concurrent
42 # access to ndbm files, you need to make sure libndbm is linked in
43 # *before* gdbm and Berkely DB.  Lastly, remember to check the
44 # "ext.libs" file which is *probably* messing up the order.  Often,
45 # you can replace ext.libs with an empty file to fix the problem.
46 #
47 # If you get a message about "too much defining", as may happen
48 # in HPUX < 10, you might have to append a single entry to your
49 # ccflags: '-Wp,-H256000'
50 # NOTE: This is a single entry (-W takes the argument 'p,-H256000').
51 #--------------------------------------------------------------------
52
53 # Turn on the _HPUX_SOURCE flag to get many of the HP add-ons
54 # regardless of compiler.  For the HP ANSI C compiler, you may also
55 # want to include +e to enable "long long" and "long double".
56 #
57 # HP compiler flags to include (if at all) *both* as part of ccflags
58 # and cc itself so Configure finds (and builds) everything
59 # consistently:
60 #       -Aa -D_HPUX_SOURCE +e
61 #
62 # Lastly, you may want to include the "-z" HP linker flag so that
63 # reading from a NULL pointer causes a SEGV.
64 ccflags="$ccflags -D_HPUX_SOURCE"
65
66 # Check if you're using the bundled C compiler.  This compiler doesn't support
67 # ANSI C (the -Aa flag) nor can it produce shared libraries.  Thus we have
68 # to turn off dynamic loading.
69 case "$cc" in
70 '') if cc $ccflags -Aa 2>&1 | $contains 'option' >/dev/null
71     then
72         case "$usedl" in
73          '') usedl="$undef"
74              cat <<'EOM' >&4
75
76 The bundled C compiler can not produce shared libraries, so you will
77 not be able to use dynamic loading. 
78
79 EOM
80              ;;
81         esac
82     else
83         ccflags="$ccflags -Aa"  # The add-on compiler supports ANSI C
84         # cppstdin and cpprun need the -Aa option if you use the unbundled 
85         # ANSI C compiler (*not* the bundled K&R compiler or gcc)
86         # [XXX this should be set automatically by Configure, but isn't yet.]
87         # [XXX This is reported not to work.  You may have to edit config.sh.
88         #  After running Configure, set cpprun and cppstdin in config.sh,
89         #  run "Configure -S" and then "make".]
90         cpprun="${cc:-cc} -E -Aa"
91         cppstdin="$cpprun"
92         cppminus='-'
93         cpplast='-'
94     fi
95     # For HP's ANSI C compiler, up to "+O3" is safe for everything
96     # except shared libraries (PIC code).  Max safe for PIC is "+O2".
97     # Setting both causes innocuous warnings.
98     #optimize='+O3'
99     #cccdlflags='+z +O2'
100     optimize='-O'
101     ;;
102 esac
103
104 # Even if you use gcc, prefer the HP math library over the GNU one.
105
106 case "`$cc -v 2>&1`" in
107 "*gcc*" ) test -d /lib/pa1.1 && ccflags="$ccflags -L/lib/pa1.1" ;;
108 esac
109
110 # Determine the architecture type of this system.
111 # Keep leading tab below -- Configure Black Magic -- RAM, 03/02/97
112         xxOsRevMajor=`uname -r | sed -e 's/^[^0-9]*//' | cut -d. -f1`;
113         #xxOsRevMinor=`uname -r | sed -e 's/^[^0-9]*//' | cut -d. -f2`;
114 if [ "$xxOsRevMajor" -ge 10 ]
115 then
116         # This system is running >= 10.x
117
118         # Tested on 10.01 PA1.x and 10.20 PA[12].x.  Idea: Scan
119         # /usr/include/sys/unistd.h for matches with "#define CPU_* `getconf
120         # CPU_VERSION`" to determine CPU type.  Note the part following
121         # "CPU_" is used, *NOT* the comment.
122         #
123         # ASSUMPTIONS: Numbers will continue to be defined in hex -- and in
124         # /usr/include/sys/unistd.h -- and the CPU_* #defines will be kept
125         # up to date with new CPU/OS releases.
126         xxcpu=`getconf CPU_VERSION`; # Get the number.
127         xxcpu=`printf '0x%x' $xxcpu`; # convert to hex
128         archname=`sed -n -e "s/^#[ \t]*define[ \t]*CPU_//p" /usr/include/sys/unistd.h |
129             sed -n -e "s/[ \t]*$xxcpu[ \t].*//p" |
130             sed -e s/_RISC/-RISC/ -e s/HP_// -e s/_/./`;
131 else
132         # This system is running <= 9.x
133         # Tested on 9.0[57] PA and [78].0 MC680[23]0.  Idea: After removing
134         # MC6888[12] from context string, use first CPU identifier.
135         #
136         # ASSUMPTION: Only CPU identifiers contain no lowercase letters.
137         archname=`getcontext | tr ' ' '\012' | grep -v '[a-z]' | grep -v MC688 |
138             sed -e 's/HP-//' -e 1q`;
139         selecttype='int *'
140 fi
141
142 # Under 10.X, a threaded perl can be built, but it needs
143 # libcma and OLD_PTHREADS_API.  Also <pthread.h> needs to
144 # be #included before any other includes (in perl.h)
145 if [ "$xxOsRevMajor" -eq 10 -a "X$usethreads" = "X$define" ]; then
146
147     if [ ! -f /usr/include/pthread.h -o ! -f /usr/lib/libcma.sl ]; then
148      cat <<EOM >&4
149 In HP-UX 10.X for threads you need both the files
150 /usr/include/pthread.h and /usr/lib/libcma.sl.
151
152 Either you must install the CMA package or you must upgrade to HP-UX 11.
153 EOM
154         exit 1
155     fi
156
157     # HP-UX 10.X uses the old pthreads API
158     case "$d_oldpthreads" in
159     '') d_oldpthreads="$define" ;;
160     esac
161
162     # include libcma before all the others
163     libswanted="cma $libswanted"
164
165     # tell perl.h to include <pthread.h> before other include files
166     ccflags="$ccflags -DPTHREAD_H_FIRST"
167
168     # CMA redefines select to cma_select, and cma_select expects int *
169     # instead of fd_set * (just like 9.X)
170     selecttype='int *'
171 fi
172
173 # Remove bad libraries that will cause problems
174 # (This doesn't remove libraries that don't actually exist)
175 # -lld is unneeded (and I can't figure out what it's used for anyway)
176 # -ldbm is obsolete and should not be used
177 # -lBSD contains BSD-style duplicates of SVR4 routines that cause confusion
178 # -lPW is obsolete and should not be used
179 # The libraries crypt, malloc, ndir, and net are empty.
180 # Although -lndbm should be included, it will make perl blow up if you should
181 # copy the binary to a system without libndbm.sl.  See ccdlflags below.
182 set `echo " $libswanted " | sed -e 's@ ld @ @' -e 's@ dbm @ @' -e 's@ BSD @ @' -e 's@ PW @ @'`
183 libswanted="$*"
184
185 # By setting the deferred flag below, this means that if you run perl
186 # on a system that does not have the required shared library that you
187 # linked it with, it will die when you try to access a symbol in the
188 # (missing) shared library.  If you would rather know at perl startup
189 # time that you are missing an important shared library, switch the
190 # comments so that immediate, rather than deferred loading is
191 # performed.  Even with immediate loading, you can postpone errors for
192 # undefined (or multiply defined) routines until actual access by
193 # adding the "nonfatal" option.
194 # ccdlflags="-Wl,-E -Wl,-B,immediate $ccdlflags"
195 # ccdlflags="-Wl,-E -Wl,-B,immediate,-B,nonfatal $ccdlflags"
196 ccdlflags="-Wl,-E -Wl,-B,deferred $ccdlflags"
197
198 usemymalloc='y'
199 alignbytes=8
200 # For native nm, you need "-p" to produce BSD format output.
201 nm_opt='-p'
202
203 # When HP-UX runs a script with "#!", it sets argv[0] to the script name.
204 toke_cflags='ccflags="$ccflags -DARG_ZERO_IS_SCRIPT"'
205
206 # If your compile complains about FLT_MIN, uncomment the next line
207 # POSIX_cflags='ccflags="$ccflags -DFLT_MIN=1.17549435E-38"'
208
209 # Comment this out if you don't want to follow the SVR4 filesystem layout
210 # that HP-UX 10.0 uses
211 case "$prefix" in
212 '') prefix='/opt/perl5' ;;
213 esac
214
215 # HP-UX can't do setuid emulation offered by Configure
216 case "$d_dosuid" in
217 '') d_dosuid="$undef" ;;
218 esac
219
220 # Date: Fri, 6 Sep 96 23:15:31 CDT
221 # From: "Daniel S. Lewart" <d-lewart@uiuc.edu>
222 # I looked through the gcc.info and found this:
223 #   * GNU CC compiled code sometimes emits warnings from the HP-UX
224 #     assembler of the form:
225 #          (warning) Use of GR3 when frame >= 8192 may cause conflict.
226 #     These warnings are harmless and can be safely ignored.
227
228 # 64-bitness.
229 # jhi@iki.fi, inspired by Jeff Okamoto.
230
231 if [ X"$use64bits" = X"$define" ]; then
232   if [ "$xxOsRevMajor" -lt 11 ]; then
233      cat <<EOM >&4
234 64-bit compilation is not supported on HP-UX $xxOsRevMajor.
235 You need at least HP-UX 11.0.
236 EOM
237      exit 1
238   fi
239   if [ ! -d /lib/pa20_64 ]; then
240      cat <<EOM >&4
241 You do not seem to have the 64-bit libraries, /lib/pa20_64.
242 EOM
243     exit 1
244   fi
245   ccflags="$ccflags +DD64 -D_FILE_OFFSET_BITS=64"
246   ldflags="$ldflags +DD64"
247   ld=/usr/bin/ld
248   set `echo " $libswanted " | sed -e 's@ dl @ @'`
249   libswanted="$*"
250   glibpth="/lib/pa20_64"
251 fi