This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade to ExtUtils-MakeMaker-6.48
[perl5.git] / lib / ExtUtils / MakeMaker / vmsish.pm
1 package ExtUtils::MakeMaker::vmsish;
2
3 use strict;
4
5 our $VERSION = 6.48;
6
7 my $IsVMS = $^O eq 'VMS';
8
9 require vmsish if $IsVMS;
10
11
12 sub import {
13     return unless $IsVMS;
14
15     shift;
16     unshift @_, 'vmsish';
17
18     goto &vmsish::import;
19 }
20
21 1;
22
23
24 =head1 NAME
25
26 ExtUtils::MakeMaker::vmsish - Platform-agnostic vmsish.pm
27
28 =head1 SYNOPSIS
29
30   use just like vmsish.pm
31
32 =head1 DESCRIPTION
33
34 Until 5.8.0, vmsish.pm is only installed on VMS.  This means any code
35 which has 'use vmsish' in it won't even compile outside VMS.  This
36 makes ExtUtils::MM_VMS very hard to test.
37
38 ExtUtils::MakeMaker::vmsish is just a very thin wrapper around vmsish
39 which works just like it on VMS and everywhere else it does nothing.
40
41 =cut