This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Fix version's test scripts' $Verbose flag
[perl5.git] / cpan / version / t / 03require.t
1 #! /usr/local/perl -w
2 # Before `make install' is performed this script should be runnable with
3 # `make test'. After `make install' it should work as `perl test.pl'
4
5 #########################
6
7 use Test::More qw/no_plan/;
8 our $Verbose;
9
10 BEGIN {
11     (my $coretests = $0) =~ s'[^/]+\.t'coretests.pm';
12     require $coretests;
13 }
14
15 # Don't want to use, because we need to make sure that the import doesn't
16 # fire just yet (some code does this to avoid importing qv() and delare()).
17 require_ok("version");
18 is $version::VERSION, 0.9903, "Make sure we have the correct class";
19 ok(!"main"->can("qv"), "We don't have the imported qv()");
20 ok(!"main"->can("declare"), "We don't have the imported declare()");
21
22
23 diag "Tests with base class" if $Verbose;
24
25 BaseTests("version","new",undef);
26 BaseTests("version","parse",undef);