This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade to Module::Load::Conditional 0.16, by Jos Boumans
[perl5.git] / lib / Module / Load / Conditional / t / 01_Module_Load_Conditional.t
1 ### Module::Load::Conditional test suite ###
2 BEGIN { 
3     if( $ENV{PERL_CORE} ) {
4         chdir '../lib/Module/Load/Conditional' 
5             if -d '../lib/Module/Load/Conditional';
6         unshift @INC, '../../../..';
7     
8         ### fix perl location too
9         $^X = '../../../../../t/' . $^X;
10     }
11
12
13 BEGIN { chdir 't' if -d 't' }
14
15 use strict;
16 use lib qw[../lib to_load];
17 use File::Spec ();
18
19 use Test::More tests => 23;
20
21 ### case 1 ###
22 use_ok( 'Module::Load::Conditional' );
23
24 ### stupid stupid warnings ###
25 {   $Module::Load::Conditional::VERBOSE =   
26     $Module::Load::Conditional::VERBOSE = 0;
27
28     *can_load       = *Module::Load::Conditional::can_load
29                     = *Module::Load::Conditional::can_load;
30     *check_install  = *Module::Load::Conditional::check_install
31                     = *Module::Load::Conditional::check_install;
32     *requires       = *Module::Load::Conditional::requires
33                     = *Module::Load::Conditional::requires;
34 }
35
36 {
37     my $rv = check_install(
38                         module  => 'Module::Load::Conditional',
39                         version => $Module::Load::Conditional::VERSION,
40                 );
41
42     ok( $rv->{uptodate},    q[Verify self] );
43     ok( $rv->{version} == $Module::Load::Conditional::VERSION,  
44                             q[  Found proper version] );
45
46     ok( $INC{'Module/Load/Conditional.pm'} eq
47         File::Spec::Unix->catfile(File::Spec->splitdir($rv->{file}) ),
48                             q[  Found proper file]
49     );
50
51 }
52
53 {
54     my $rv = check_install(
55                         module  => 'Module::Load::Conditional',
56                         version => $Module::Load::Conditional::VERSION + 1,
57                 );
58
59     ok( !$rv->{uptodate} && $rv->{version} && $rv->{file},
60         q[Verify out of date module]
61     );
62 }
63
64 {
65     my $rv = check_install( module  => 'Module::Load::Conditional' );
66
67     ok( $rv->{uptodate} && $rv->{version} && $rv->{file},
68         q[Verify any module]
69     );
70 }
71
72 {
73     my $rv = check_install( module  => 'Module::Does::Not::Exist' );
74
75     ok( !$rv->{uptodate} && !$rv->{version} && !$rv->{file},
76         q[Verify non-existant module]
77     );
78
79 }
80
81 ### test finding a version of a module that mentions $VERSION in pod
82 {   my $rv = check_install( module => 'InPod' );
83     ok( $rv,                        'Testing $VERSION in POD' );
84     ok( $rv->{version},             "   Version found" );
85     is( $rv->{version}, 2,          "   Version is correct" );
86 }
87
88 ### test $FIND_VERSION
89 {   local $Module::Load::Conditional::FIND_VERSION = 0;
90     local $Module::Load::Conditional::FIND_VERSION = 0;
91     
92     my $rv = check_install( module  => 'Module::Load::Conditional' );
93
94     ok( $rv,                        'Testing $FIND_VERSION' );
95     is( $rv->{version}, undef,      "   No version info returned" );
96     ok( $rv->{uptodate},            "   Module marked as uptodate" );
97 }    
98
99 ### test 'can_load' ###
100
101 {
102     my $use_list = { 'LoadIt' => 1 };
103     my $bool = can_load( modules => $use_list );
104
105     ok( $bool, q[Load simple module] );
106 }
107
108 {
109     my $use_list = { 'Commented' => 2 };
110     my $bool = can_load( modules => $use_list );
111
112     ok( $bool, q[Load module with a second, commented-out $VERSION] );
113 }
114
115 {
116     my $use_list = { 'Must::Be::Loaded' => 1 };
117     my $bool = can_load( modules => $use_list );
118
119     ok( !$bool, q[Detect out of date module] );
120 }
121
122 {
123     delete $INC{'LoadIt.pm'};
124     delete $INC{'Must/Be/Loaded.pm'};
125
126     my $use_list = { 'LoadIt' => 1, 'Must::Be::Loaded' => 1 };
127     my $bool = can_load( modules => $use_list );
128
129     ok( !$INC{'LoadIt.pm'} && !$INC{'Must/Be/Loaded.pm'},
130         q[Do not load if one prerequisite fails]
131     );
132 }
133
134
135 ### test 'requires' ###
136 SKIP:{
137     skip "Depends on \$^X, which doesn't work well when testing the Perl core", 
138         1 if $ENV{PERL_CORE};
139
140     my %list = map { $_ => 1 } requires('Carp');
141     
142     my $flag;
143     $flag++ unless delete $list{'Exporter'};
144
145     ok( !$flag, q[Detecting requirements] );
146 }
147
148 ### test using the %INC lookup for check_install
149 {   local $Module::Load::Conditional::CHECK_INC_HASH = 1;
150     local $Module::Load::Conditional::CHECK_INC_HASH = 1;
151     
152     {   package A::B::C::D; 
153         $A::B::C::D::VERSION = $$; 
154         $INC{'A/B/C/D.pm'}   = $$.$$;
155     }
156     
157     my $href = check_install( module => 'A::B::C::D', version => 0 );
158
159     ok( $href,                  'Found package in %INC' );
160     is( $href->{'file'}, $$.$$, '   Found correct file' );
161     is( $href->{'version'}, $$, '   Found correct version' );
162     ok( $href->{'uptodate'},    '   Marked as uptodate' );
163     ok( can_load( modules => { 'A::B::C::D' => 0 } ),
164                                 '   can_load successful' );
165 }
166
167