This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
8d026375d2c4a76e7fd44620c82026e55a01e32a
[perl5.git] / hints / hpux.sh
1 #! /bin/sh
2
3 # hints/hpux.sh
4 # Perl Configure hints file for Hewlett-Packard's HP-UX 9.x and 10.x
5 # (Hopefully, 7.x through 11.x.)
6 #
7 # This file is based on hints/hpux_9.sh, Perl Configure hints file for
8 # Hewlett Packard HP-UX 9.x
9 #
10 # Use Configure -Dcc=gcc to use gcc.
11 #
12 # From: Jeff Okamoto <okamoto@corp.hp.com>
13 # and
14 # hints/hpux_10.sh, Perl Configure hints file for Hewlett Packard HP-UX 10.x
15 # From: Giles Lean <giles@nemeton.com.au>
16 # and
17 # Use #define CPU_* instead of comments for >= 10.x.
18 # Support PA1.2 under 10.x.
19 # Distinguish between PA2.0, PA2.1, etc.
20 # Distinguish between MC68020, MC68030, MC68040
21 # Don't assume every OS != 10 is < 10, (e.g., 11).
22 # From: Chuck Phillips <cdp@fc.hp.com>
23 # HP-UX 10 pthreads hints: Matthew T Harden <mthard@mthard1.monsanto.com>
24
25 # This version: August 15, 1997
26 # Current maintainer: Jeff Okamoto <okamoto@corp.hp.com>
27
28 #--------------------------------------------------------------------
29 # Use Configure -Dcc=gcc to use gcc.
30 # Use Configure -Dprefix=/usr/local to install in /usr/local.
31 #
32 # You may have dynamic loading problems if the environment variable
33 # LDOPTS='-a archive'.  Under >= 10.x, you can instead LDOPTS='-a
34 # archive_shared' to prefer archive libraries without requiring them.
35 # Regardless of HPUX release, in the "libs" variable or the ext.libs
36 # file, you can always give explicit path names to archive libraries
37 # that may not exist on the target machine.  E.g., /usr/lib/libndbm.a
38 # instead of -lndbm.  See also note below on ndbm.
39 #
40 # ALSO, bear in mind that gdbm and Berkely DB contain incompatible
41 # replacements for ndbm (and dbm) routines.  If you want concurrent
42 # access to ndbm files, you need to make sure libndbm is linked in
43 # *before* gdbm and Berkely DB.  Lastly, remember to check the
44 # "ext.libs" file which is *probably* messing up the order.  Often,
45 # you can replace ext.libs with an empty file to fix the problem.
46 #
47 # If you get a message about "too much defining", as may happen
48 # in HPUX < 10, you might have to append a single entry to your
49 # ccflags: '-Wp,-H256000'
50 # NOTE: This is a single entry (-W takes the argument 'p,-H256000').
51 #--------------------------------------------------------------------
52
53 # Turn on the _HPUX_SOURCE flag to get many of the HP add-ons
54 # regardless of compiler.  For the HP ANSI C compiler, you may also
55 # want to include +e to enable "long long" and "long double".
56 #
57 # HP compiler flags to include (if at all) *both* as part of ccflags
58 # and cc itself so Configure finds (and builds) everything
59 # consistently:
60 #       -Aa -D_HPUX_SOURCE +e
61 #
62 # Lastly, you may want to include the "-z" HP linker flag so that
63 # reading from a NULL pointer causes a SEGV.
64 ccflags="$ccflags -D_HPUX_SOURCE"
65
66 # Check if you're using the bundled C compiler.  This compiler doesn't support
67 # ANSI C (the -Aa flag) nor can it produce shared libraries.  Thus we have
68 # to turn off dynamic loading.
69 case "$cc" in
70 '') if cc $ccflags -Aa 2>&1 | $contains 'option' >/dev/null
71     then
72         case "$usedl" in
73          '') usedl="$undef"
74              cat <<'EOM' >&4
75
76 The bundled C compiler can not produce shared libraries, so you will
77 not be able to use dynamic loading. 
78
79 EOM
80              ;;
81         esac
82     else
83         ccflags="$ccflags -Aa"  # The add-on compiler supports ANSI C
84         # cppstdin and cpprun need the -Aa option if you use the unbundled 
85         # ANSI C compiler (*not* the bundled K&R compiler or gcc)
86         # [XXX this should be set automatically by Configure, but isn't yet.]
87         # [XXX This is reported not to work.  You may have to edit config.sh.
88         #  After running Configure, set cpprun and cppstdin in config.sh,
89         #  run "Configure -S" and then "make".]
90         cpprun="${cc:-cc} -E -Aa"
91         cppstdin="$cpprun"
92         cppminus='-'
93         cpplast='-'
94     fi
95     # For HP's ANSI C compiler, up to "+O3" is safe for everything
96     # except shared libraries (PIC code).  Max safe for PIC is "+O2".
97     # Setting both causes innocuous warnings.
98     #optimize='+O3'
99     #cccdlflags='+z +O2'
100     optimize='-O'
101     ;;
102 esac
103
104 # Determine the architecture type of this system.
105 # Keep leading tab below -- Configure Black Magic -- RAM, 03/02/97
106         xxOsRevMajor=`uname -r | sed -e 's/^[^0-9]*//' | cut -d. -f1`;
107         #xxOsRevMinor=`uname -r | sed -e 's/^[^0-9]*//' | cut -d. -f2`;
108 if [ "$xxOsRevMajor" -ge 10 ]
109 then
110         # This system is running >= 10.x
111
112         # Tested on 10.01 PA1.x and 10.20 PA[12].x.  Idea: Scan
113         # /usr/include/sys/unistd.h for matches with "#define CPU_* `getconf
114         # CPU_VERSION`" to determine CPU type.  Note the part following
115         # "CPU_" is used, *NOT* the comment.
116         #
117         # ASSUMPTIONS: Numbers will continue to be defined in hex -- and in
118         # /usr/include/sys/unistd.h -- and the CPU_* #defines will be kept
119         # up to date with new CPU/OS releases.
120         xxcpu=`getconf CPU_VERSION`; # Get the number.
121         xxcpu=`printf '0x%x' $xxcpu`; # convert to hex
122         archname=`sed -n -e "s/^#[ \t]*define[ \t]*CPU_//p" /usr/include/sys/unistd.h |
123             sed -n -e "s/[ \t]*$xxcpu[ \t].*//p" |
124             sed -e s/_RISC/-RISC/ -e s/HP_// -e s/_/./`;
125 else
126         # This system is running <= 9.x
127         # Tested on 9.0[57] PA and [78].0 MC680[23]0.  Idea: After removing
128         # MC6888[12] from context string, use first CPU identifier.
129         #
130         # ASSUMPTION: Only CPU identifiers contain no lowercase letters.
131         archname=`getcontext | tr ' ' '\012' | grep -v '[a-z]' | grep -v MC688 |
132             sed -e 's/HP-//' -e 1q`;
133         selecttype='int *'
134 fi
135
136 case "$use64bitint" in
137 $define|true|[yY]*)
138     if [ "$xxOsRevMajor" -lt 11 ]; then
139                 cat <<EOM >&4
140
141 64-bit compilation is not supported on HP-UX $xxOsRevMajor.
142 You need at least HP-UX 11.0.
143 Cannot continue, aborting.
144
145 EOM
146                 exit 1
147     fi
148
149     # Without the 64-bit libc we cannot do much.
150     if [ ! -f /lib/pa20_64/libc.sl ]; then
151                 cat <<EOM >&4
152
153 You do not seem to have the 64-bit libraries in /lib/pa20_64.
154 Most importantly, I cannot find /lib/pa20_64/libc.sl.
155 Cannot continue, aborting.
156
157 EOM
158                 exit 1
159     fi
160
161     ccflags="$ccflags +DD64"
162     ldflags="$ldflags +DD64"
163     test -d /lib/pa20_64 && loclibpth="$loclibpth /lib/pa20_64"
164     libscheck='case "`file $xxx`" in
165 *LP64*|*PA-RISC2.0*) ;;
166 *) xxx=/no/64-bit$xxx ;;
167 esac'
168     ld=/usr/bin/ld
169     ar=/usr/bin/ar
170     full_ar=$ar
171
172     # The strict ANSI mode (-Aa) doesn't like the LL suffixes.
173     case "$ccflags" in
174     *-Aa*)
175             echo "(Changing from strict ANSI compilation to extended because of 64-bitness)"
176             ccflags=`echo $ccflags|sed 's@ -Aa @ -Ae @'`
177             ;;
178     esac    
179
180     set `echo " $libswanted " | sed -e 's@ dl @ @'`
181     libswanted="$*"
182
183     case "`$cc -v 2>&1`" in
184     *gcc*) test -d /lib/pa20_64 && ccflags="$ccflags -L/lib/pa20_64" ;;
185     esac
186     ;;
187 *) loclibpth="$loclibpth /lib/pa1.1"
188     case "`$cc -v 2>&1`" in
189     *gcc*) test -d /lib/pa20_64 && ccflags="$ccflags -L/lib/pa20_64" ;;
190     esac
191     ;;
192 esac
193
194 case "`getconf KERNEL_BITS 2>/dev/null`" in
195 *64*) ldflags="$ldflags -Wl,+vnocompatwarnings" ;;
196 esac
197
198 # Remove bad libraries that will cause problems
199 # (This doesn't remove libraries that don't actually exist)
200 # -lld is unneeded (and I can't figure out what it's used for anyway)
201 # -ldbm is obsolete and should not be used
202 # -lBSD contains BSD-style duplicates of SVR4 routines that cause confusion
203 # -lPW is obsolete and should not be used
204 # The libraries crypt, malloc, ndir, and net are empty.
205 # Although -lndbm should be included, it will make perl blow up if you should
206 # copy the binary to a system without libndbm.sl.  See ccdlflags below.
207 set `echo " $libswanted " | sed -e 's@ ld @ @' -e 's@ dbm @ @' -e 's@ BSD @ @' -e 's@ PW @ @'`
208 libswanted="$*"
209
210 # By setting the deferred flag below, this means that if you run perl
211 # on a system that does not have the required shared library that you
212 # linked it with, it will die when you try to access a symbol in the
213 # (missing) shared library.  If you would rather know at perl startup
214 # time that you are missing an important shared library, switch the
215 # comments so that immediate, rather than deferred loading is
216 # performed.  Even with immediate loading, you can postpone errors for
217 # undefined (or multiply defined) routines until actual access by
218 # adding the "nonfatal" option.
219 # ccdlflags="-Wl,-E -Wl,-B,immediate $ccdlflags"
220 # ccdlflags="-Wl,-E -Wl,-B,immediate,-B,nonfatal $ccdlflags"
221 ccdlflags="-Wl,-E -Wl,-B,deferred $ccdlflags"
222
223 usemymalloc='y'
224 alignbytes=8
225 # For native nm, you need "-p" to produce BSD format output.
226 nm_opt='-p'
227
228 # When HP-UX runs a script with "#!", it sets argv[0] to the script name.
229 toke_cflags='ccflags="$ccflags -DARG_ZERO_IS_SCRIPT"'
230
231 # If your compile complains about FLT_MIN, uncomment the next line
232 # POSIX_cflags='ccflags="$ccflags -DFLT_MIN=1.17549435E-38"'
233
234 # Comment this out if you don't want to follow the SVR4 filesystem layout
235 # that HP-UX 10.0 uses
236 case "$prefix" in
237 '') prefix='/opt/perl5' ;;
238 esac
239
240 # HP-UX can't do setuid emulation offered by Configure
241 case "$d_dosuid" in
242 '') d_dosuid="$undef" ;;
243 esac
244
245 # HP-UX 11 groks also LD_LIBRARY_PATH but SHLIB_PATH
246 # is recommended for compatibility.
247 case "$ldlibpthname" in
248 '') ldlibpthname=SHLIB_PATH ;;
249 esac
250
251 # HP-UX 10.20 and gcc 2.8.1 break UINT32_MAX.
252 case "$cc" in
253 *gcc*) ccflags="$ccflags -DUINT32_MAX_BROKEN" ;;
254 esac
255
256 cat > UU/cc.cbu <<'EOSH'
257 # XXX This script UU/cc.cbu will get 'called-back' by Configure after it
258 # XXX has prompted the user for the C compiler to use.
259 # Get gcc to share its secrets.
260 echo 'main() { return 0; }' > try.c
261         # Indent to avoid propagation to config.sh
262         verbose=`${cc:-cc} -v -o try try.c 2>&1`
263 if echo "$verbose" | grep '^Reading specs from' >/dev/null 2>&1; then
264         # Using gcc.
265         : nothing to see here, move on.
266 else
267         # Using cc.
268         ar=${ar:-ar}
269         case "`$ar -V 2>&1`" in
270         *GNU*)
271             if test -x /usr/bin/ar; then
272                 cat <<END >&2
273
274 NOTE: You are using HP cc(1) but GNU ar(1).  This might lead into trouble
275 later on, I'm switching to HP ar to play safe.
276 END
277                 ar=/usr/bin/ar
278             fi
279         ;;
280     esac
281 fi
282
283 EOSH
284
285 # Date: Fri, 6 Sep 96 23:15:31 CDT
286 # From: "Daniel S. Lewart" <d-lewart@uiuc.edu>
287 # I looked through the gcc.info and found this:
288 #   * GNU CC compiled code sometimes emits warnings from the HP-UX
289 #     assembler of the form:
290 #          (warning) Use of GR3 when frame >= 8192 may cause conflict.
291 #     These warnings are harmless and can be safely ignored.
292
293 # This script UU/usethreads.cbu will get 'called-back' by Configure 
294 # after it has prompted the user for whether to use threads.
295 cat > UU/usethreads.cbu <<'EOCBU'
296 case "$usethreads" in
297 $define|true|[yY]*)
298         if [ "$xxOsRevMajor" -lt 10 ]; then
299             cat <<EOM >&4
300 HP-UX $xxOsRevMajor cannot support POSIX threads.
301 Consider upgrading to at least HP-UX 11.
302 Cannot continue, aborting.
303 EOM
304             exit 1
305         fi
306         case "$xxOsRevMajor" in
307         10)
308             # Under 10.X, a threaded perl can be built, but it needs
309             # libcma and OLD_PTHREADS_API.  Also <pthread.h> needs to
310             # be #included before any other includes (in perl.h)
311             if [ ! -f /usr/include/pthread.h -o ! -f /usr/lib/libcma.sl ]; then
312                 cat <<EOM >&4
313 In HP-UX 10.X for POSIX threads you need both of the files
314 /usr/include/pthread.h and /usr/lib/libcma.sl.
315 Either you must install the CMA package or you must upgrade to HP-UX 11.
316 Cannot continue, aborting.
317 EOM
318                 exit 1
319             fi
320
321             # HP-UX 10.X uses the old pthreads API
322             case "$d_oldpthreads" in
323             '') d_oldpthreads="$define" ;;
324             esac
325
326             # include libcma before all the others
327             libswanted="cma $libswanted"
328
329             # tell perl.h to include <pthread.h> before other include files
330             ccflags="$ccflags -DPTHREAD_H_FIRST"
331
332             # CMA redefines select to cma_select, and cma_select expects int *
333             # instead of fd_set * (just like 9.X)
334             selecttype='int *'
335             ;;
336         11 | 12) # 12 may want upping the _POSIX_C_SOURCE datestamp...
337             ccflags=" -D_POSIX_C_SOURCE=199506L $ccflags"
338             set `echo X "$libswanted "| sed -e 's/ c / pthread c /'`
339             shift
340             libswanted="$*"
341             ;;
342         esac
343         usemymalloc='n'
344         ;;
345 esac
346 EOCBU
347
348 # This script UU/uselfs.cbu will get 'called-back' by Configure 
349 # after it has prompted the user for whether to use 64 bits.
350 cat > UU/uselfs.cbu <<'EOCBU'
351 case "$uselargefiles" in
352 ''|$define|true|[yY]*)
353         # there are largefile flags available via getconf(1)
354         # but we cheat for now.
355         ccflags="$ccflags -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
356
357         # The strict ANSI mode (-Aa) doesn't like large files.
358         case "$ccflags" in
359         *-Aa*)
360             echo "(Changing from strict ANSI compilation to extended because of large files)"
361             ccflags=`echo $ccflags|sed 's@ -Aa @ -Ae @'`
362             ;;
363         esac    
364         ;;
365 esac
366 EOCBU
367
368