This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
DB_File-1.74
[perl5.git] / ext / DB_File / version.c
1 /* 
2
3  version.c -- Perl 5 interface to Berkeley DB 
4
5  written by Paul Marquess <Paul.Marquess@btinternet.com>
6  last modified 16th January 2000
7  version 1.73
8
9  All comments/suggestions/problems are welcome
10
11      Copyright (c) 1995-2000 Paul Marquess. All rights reserved.
12      This program is free software; you can redistribute it and/or
13      modify it under the same terms as Perl itself.
14
15  Changes:
16         1.71 -  Support for Berkeley DB version 3.
17                 Support for Berkeley DB 2/3's backward compatability mode.
18         1.72 -  No change.
19         1.73 -  Added support for threading
20         1.74 -  Added Perl core patch 7801.
21
22
23 */
24
25 #include "EXTERN.h"  
26 #include "perl.h"
27 #include "XSUB.h"
28
29 #include <db.h>
30
31 void
32 #ifdef CAN_PROTOTYPE
33 __getBerkeleyDBInfo(void)
34 #else
35 __getBerkeleyDBInfo()
36 #endif
37 {
38 #ifdef dTHX     
39     dTHX;
40 #endif    
41     SV * version_sv = perl_get_sv("DB_File::db_version", GV_ADD|GV_ADDMULTI) ;
42     SV * ver_sv = perl_get_sv("DB_File::db_ver", GV_ADD|GV_ADDMULTI) ;
43     SV * compat_sv = perl_get_sv("DB_File::db_185_compat", GV_ADD|GV_ADDMULTI) ;
44
45 #ifdef DB_VERSION_MAJOR
46     int Major, Minor, Patch ;
47
48     (void)db_version(&Major, &Minor, &Patch) ;
49
50     /* Check that the versions of db.h and libdb.a are the same */
51     if (Major != DB_VERSION_MAJOR || Minor != DB_VERSION_MINOR 
52                 || Patch != DB_VERSION_PATCH)
53         croak("\nDB_File needs compatible versions of libdb & db.h\n\tyou have db.h version %d.%d.%d and libdb version %d.%d.%d\n",  
54                 DB_VERSION_MAJOR, DB_VERSION_MINOR, DB_VERSION_PATCH, 
55                 Major, Minor, Patch) ;
56     
57     /* check that libdb is recent enough  -- we need 2.3.4 or greater */
58     if (Major == 2 && (Minor < 3 || (Minor ==  3 && Patch < 4)))
59         croak("DB_File needs Berkeley DB 2.3.4 or greater, you have %d.%d.%d\n",
60                  Major, Minor, Patch) ;
61  
62     {
63         char buffer[40] ;
64         sprintf(buffer, "%d.%d", Major, Minor) ;
65         sv_setpv(version_sv, buffer) ; 
66         sprintf(buffer, "%d.%03d%03d", Major, Minor, Patch) ;
67         sv_setpv(ver_sv, buffer) ; 
68     }
69  
70 #else /* ! DB_VERSION_MAJOR */
71     sv_setiv(version_sv, 1) ;
72     sv_setiv(ver_sv, 1) ;
73 #endif /* ! DB_VERSION_MAJOR */
74
75 #ifdef COMPAT185
76     sv_setiv(compat_sv, 1) ;
77 #else /* ! COMPAT185 */
78     sv_setiv(compat_sv, 0) ;
79 #endif /* ! COMPAT185 */
80
81 }