This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade version from version 0.9908 to 0.9909
[perl5.git] / cpan / version / t / 08_corelist.t
... / ...
CommitLineData
1#! /usr/local/perl -w
2# Before `make install' is performed this script should be runnable with
3# `make test'. After `make install' it should work as `perl test.pl'
4
5#########################
6
7use Test::More tests => 3;
8use_ok("version", 0.9909);
9
10# do strict lax tests in a sub to isolate a package to test importing
11SKIP: {
12 eval "use Module::CoreList 2.76";
13 skip 'No tied hash in Modules::CoreList in Perl', 2
14 if $@;
15
16 my $foo = version->parse($Module::CoreList::version{5.008_000}{base});
17
18 is $foo, 1.03, 'Correctly handle tied hash';
19
20 $foo = version->qv($Module::CoreList::version{5.008_000}{Unicode});
21 is $foo, '3.2.0', 'Correctly handle tied hash with dotted decimal';
22}