This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Metaconfig and Porting patches from Andy; start using the new
[perl5.git] / patchlevel.h
CommitLineData
f7d144c8 1#ifndef __PATCHLEVEL_H_INCLUDED__
4d8076ea 2
a9fb271f
GS
3/* do not adjust the whitespace! Configure expects the numbers to be
4 * exactly on the third column */
5
6#define PERL_REVISION 5 /* age */
7#define PERL_VERSION 5 /* epoch */
a7cb1f99 8#define PERL_SUBVERSION 640 /* generation */
4d8076ea 9
273cf8d1
GS
10/* The following numbers describe the earliest compatible version of
11 Perl ("compatibility" here being defined as sufficient binary/API
12 compatibility to run XS code built with the older version).
75347591 13 Normally this should not change across maintenance releases.
75347591 14
ff935051
JH
15 This is used by Configure et al to figure out
16 PERL_INC_VERSION_LIST, which lists version libraries
17 to include in @INC. See INSTALL for how this works.
75347591 18*/
273cf8d1
GS
19#define PERL_API_REVISION 5 /* Adjust manually as needed. */
20#define PERL_API_VERSION 5 /* Adjust manually as needed. */
21#define PERL_API_SUBVERSION 640 /* Adjust manually as needed. */
ff935051
JH
22/*
23 XXX Note: The selection of non-default Configure options, such
24 as -Duselonglong may invalidate these settings. Currently, Configure
25 does not adequately test for this. A.D. Jan 13, 2000
26*/
75347591 27
e3321bb0
GS
28#define __PATCHLEVEL_H_INCLUDED__
29#endif
30
7f0a50ff
PP
31/*
32 local_patches -- list of locally applied less-than-subversion patches.
33 If you're distributing such a patch, please give it a name and a
34 one-line description, placed just before the last NULL in the array
35 below. If your patch fixes a bug in the perlbug database, please
36 mention the bugid. If your patch *IS* dependent on a prior patch,
37 please place your applied patch line after its dependencies. This
38 will help tracking of patch dependencies.
39
40 Please edit the hunk of diff which adds your patch to this list,
41 to remove context lines which would give patch problems. For instance,
42 if the original context diff is
43 *** patchlevel.h.orig <date here>
44 --- patchlevel.h <date here>
45 *** 38,43 ***
46 --- 38,44 ---
47 ,"FOO1235 - some patch"
48 ,"BAR3141 - another patch"
49 ,"BAZ2718 - and another patch"
50 + ,"MINE001 - my new patch"
51 ,NULL
52 };
53
54 please change it to
55 *** patchlevel.h.orig <date here>
56 --- patchlevel.h <date here>
57 *** 41,43 ***
58 --- 41,44 ---
59 + ,"MINE001 - my new patch"
60 };
61
62 (Note changes to line numbers as well as removal of context lines.)
63 This will prevent patch from choking if someone has previously
64 applied different patches than you.
65 */
e3321bb0 66#if !defined(PERL_PATCHLEVEL_H_IMPLICIT) && !defined(LOCAL_PATCH_COUNT)
7f0a50ff
PP
67static char *local_patches[] = {
68 NULL
69 ,NULL
70};
71
b33f1439
PP
72/* Initial space prevents this variable from being inserted in config.sh */
73# define LOCAL_PATCH_COUNT \
7f0a50ff 74 (sizeof(local_patches)/sizeof(local_patches[0])-2)
f7d144c8 75
cceca5ed 76/* the old terms of reference, add them only when explicitly included */
cceca5ed
GS
77#define PATCHLEVEL PERL_VERSION
78#undef SUBVERSION /* OS/390 has a SUBVERSION in a system header */
79#define SUBVERSION PERL_SUBVERSION
80#endif