This is a live mirror of the Perl 5 development currently hosted at https://github.com/perl/perl5
Upgrade version from version 0.9908 to 0.9909
[perl5.git] / cpan / version / t / 03require.t
CommitLineData
543eec9e
JP
1#! /usr/local/perl -w
2# Before `make install' is performed this script should be runnable with
3# `make test'. After `make install' it should work as `perl test.pl'
4
5#########################
6
7use Test::More qw/no_plan/;
8
9BEGIN {
10 (my $coretests = $0) =~ s'[^/]+\.t'coretests.pm';
11 require $coretests;
12}
13
14# Don't want to use, because we need to make sure that the import doesn't
15# fire just yet (some code does this to avoid importing qv() and delare()).
16require_ok("version");
da891a41 17is $version::VERSION, 0.9909, "Make sure we have the correct class";
543eec9e
JP
18ok(!"main"->can("qv"), "We don't have the imported qv()");
19ok(!"main"->can("declare"), "We don't have the imported declare()");
20
543eec9e
JP
21BaseTests("version","new",undef);
22BaseTests("version","parse",undef);