autodoc.pl needs -Ilib. I had been testing with a perl that was also installed.