base: no longer works on v5.6, require v5.8
authorRicardo Signes <rjbs@cpan.org>
Fri, 13 Nov 2015 16:27:56 +0000 (11:27 -0500)
committerRicardo Signes <rjbs@cpan.org>
Fri, 13 Nov 2015 16:27:56 +0000 (11:27 -0500)
dist/base/Changes
dist/base/Makefile.PL
dist/base/lib/base.pm
dist/base/lib/fields.pm

index 2de35bb..c4cbb18 100644 (file)
@@ -1,3 +1,8 @@
+2.22_01
+    - require perl v5.8.0; tests for [perl #121196] break on 5.6.1, and
+      I (rjbs) am not comfortable spending time determining whether the fault
+      lies for a 15 year old version of perl
+
 2.22
     - Better handling of attempts to load non-existent modules
     - Improvements to fields.pm documentation
index a62b968..3ae4244 100644 (file)
@@ -1,3 +1,4 @@
+use 5.008;
 use strict;
 use ExtUtils::MakeMaker;
 
index 5d13787..7eff8b2 100644 (file)
@@ -1,9 +1,10 @@
+use 5.008;
 package base;
 
 use strict 'vars';
 use vars qw($VERSION);
-$VERSION = '2.22';
-$VERSION = eval $VERSION;
+$VERSION = '2.22_01';
+$VERSION =~ tr/_//d;
 
 # constant.pm is slow
 sub SUCCESS () { 1 }
index ad1a5cf..630f8ce 100644 (file)
@@ -1,3 +1,4 @@
+use 5.008;
 package fields;
 
 require 5.005;
@@ -11,7 +12,8 @@ unless( eval q{require warnings::register; warnings::register->import; 1} ) {
 }
 use vars qw(%attr $VERSION);
 
-$VERSION = '2.17';
+$VERSION = '2.22_01';
+$VERSION =~ tr/_//d;
 
 # constant.pm is slow
 sub PUBLIC     () { 2**0  }