Add 'configure_requires' to perldelta enhancements
authorDavid Golden <dagolden@cpan.org>
Wed, 1 Jul 2009 11:22:29 +0000 (07:22 -0400)
committerDavid Mitchell <davem@iabyn.com>
Fri, 3 Jul 2009 12:06:27 +0000 (13:06 +0100)
pod/perl5101delta.pod

index 0978276..1790913 100644 (file)
@@ -211,6 +211,16 @@ interact with their job schedulers.
 
 XXX do we now have dtrace?
 
+=head2 Support for C<configure_requires> in CPAN module metadata
+
+Both C<CPAN.pm> and C<CPANPLUS> now support the C<configure_requires> keyword
+in the C<META.yml> metadata file included in most recent CPAN distributions.
+This allows distribution authors to specify configuration prerequisites that
+must be installed before running Makefile.PL or Build.PL.
+
+See the documentation for C<ExtUtils::MakeMaker> or C<Module::Build> for more
+on how to specify C<configure_requires> when creating a distribution for CPAN.
+
 =head1 Modules and Pragmata
 
 =head2 New Modules