Re: Compiling perl (5.10.x) with gcc <= 3.2.3
authorAndy Dougherty <doughera@lafayette.edu>
Fri, 16 May 2008 13:59:41 +0000 (09:59 -0400)
committerH.Merijn Brand <h.m.brand@xs4all.nl>
Sat, 17 May 2008 13:48:16 +0000 (13:48 +0000)
Message-ID: <Pine.LNX.4.64.0805161344570.10409@fractal.phys.lafayette.edu>

p4raw-id: //depot/perl@33841

INSTALL

diff --git a/INSTALL b/INSTALL
index 7c16f9b..c7055a7 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -1886,6 +1886,13 @@ test, it does not necessarily mean you have a broken perl.  This test
 tries to exercise the regular expression subsystem quite thoroughly,
 and may well be far more demanding than your normal usage.
 
+=item libgcc_s.so.1: cannot open shared object file
+
+This message has been reported on gcc-3.2.3 and earlier installed with
+a non-standard prefix.  Setting the LD_LIBRARY_PATH environment variable
+(or equivalent) to include gcc's lib/ directory with the libgcc_s.so.1
+shared library should fix the problem.
+
 =item Failures from lib/File/Temp/t/security saying "system possibly insecure"
 
 First, such warnings are not necessarily serious or indicative of a