Re: [perl #24367] [PATCH] configure flag -Dextras="HTML::Parser" doesn't seem to...
authorAndy Dougherty <doughera@lafayette.edu>
Fri, 31 Oct 2003 15:32:35 +0000 (10:32 -0500)
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>
Fri, 31 Oct 2003 20:46:44 +0000 (20:46 +0000)
Message-ID: <Pine.SOL.4.53.0310311433440.8552@maxwell.phys.lafayette.edu>
(plus POD link fixes)

p4raw-id: //depot/perl@21596

INSTALL

diff --git a/INSTALL b/INSTALL
index 1ea3e7b..8fc3fe0 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -1084,7 +1084,7 @@ You can actually specify -g and -DDEBUGGING independently, but usually
 it's convenient to have both.
 
 If you are using a shared libperl, see the warnings about multiple
-versions of perl under L<Building a shared libperl.so Perl library>.
+versions of perl under L<Building a shared Perl library>.
 
 =head2 Extensions
 
@@ -1109,6 +1109,9 @@ convenient way to do that in one step.  (It is not necessary, however;
 you can build and install extensions just fine even if you don't have
 dynamic loading.  See lib/ExtUtils/MakeMaker.pm for more details.)
 
+If you have dynamic loading, another way of specifying extra modules
+is described in L<"Adding extra modules to the build"> below.
+
 You can learn more about each of the supplied extensions by consulting the
 documentation in the individual .pm modules, located under the
 ext/ subdirectory.
@@ -1471,6 +1474,9 @@ command line parameter to Configure, for example like this:
 or answer first 'y' to the question 'Install any extra modules?' and
 then answer "Compress::Zlib Bundle::LWP DBI" to the 'Extras?' question.
 The module or the bundle names are as for the CPAN module 'install' command.
+This will only work if those modules are to be built as dynamic
+extensions.  If you wish to include those extra modules as static
+extensions, see L<"Extensions"> above.
 
 Notice that because the CPAN module will be used to fetch the extra
 modules, you will need access to the CPAN, either via the Internet,
@@ -1790,7 +1796,7 @@ archive, please report it to the site's maintainer.
 =item invalid token: ##
 
 You are using a non-ANSI-compliant C compiler.  See L<WARNING:  This
-version requires a compiler that supports ANSI C>.
+version requires a compiler that supports ANSI C.>
 
 =item Miscellaneous