Deprecate open2.pl with a warning
authorSteffen Mueller <smueller@cpan.org>
Wed, 2 Sep 2009 21:03:48 +0000 (23:03 +0200)
committerSteffen Mueller <smueller@cpan.org>
Wed, 2 Sep 2009 21:03:48 +0000 (23:03 +0200)
lib/open2.pl

index 8cf08c2..5c24a3c 100644 (file)
@@ -1,3 +1,6 @@
+# This legacy library is deprecated and will be removed in a future
+# release of perl.
+#
 # This is a compatibility interface to IPC::Open2.  New programs should
 # do
 #
@@ -7,6 +10,10 @@
 #
 #     require 'open2.pl';
 
+warn( "The 'open2.pl' legacy library is deprecated and will be"
+      . " removed in the next major release of perl. Please use the"
+      . " IPC::Open2 module instead." );
+
 package main;
 use IPC::Open2 'open2';
 1