Update Parse::CPAN::Meta to 1.39
authorSteffen Mueller <smueller@cpan.org>
Sat, 6 Jun 2009 09:49:23 +0000 (11:49 +0200)
committerSteffen Mueller <smueller@cpan.org>
Sat, 6 Jun 2009 09:49:23 +0000 (11:49 +0200)
lib/Parse/CPAN/Meta.pm
lib/Parse/CPAN/Meta/Changes
lib/Parse/CPAN/Meta/t/15_multibyte.t

index 2537ca5..a06556e 100644 (file)
@@ -15,7 +15,7 @@ BEGIN {
        # Class structure
        require 5.004;
        require Exporter;
-       $Parse::CPAN::Meta::VERSION   = '1.38';
+       $Parse::CPAN::Meta::VERSION   = '1.39';
        @Parse::CPAN::Meta::ISA       = qw{ Exporter      };
        @Parse::CPAN::Meta::EXPORT_OK = qw{ Load LoadFile };
 }
index 21fc896..107b969 100644 (file)
@@ -1,4 +1,8 @@
-Revision history for Perl extension Parse-CPAN-Meta
+Changes for Perl programming language extension Parse-CPAN-Meta
+
+1.39 Thu 21 May 2009
+       - Even though utf8 starts at 5.7+ there's no is_utf till
+         5.8.1 so skip in the tests if needed (ADAMK)
 
 1.38 Sat 16 May 2009
        - Synchorised version numbers with YAML::Tiny
index 214b8b0..cdde728 100644 (file)
@@ -48,6 +48,12 @@ SKIP: {
 }
 
 SKIP: {
-       skip "no utf8 support", 1 unless Parse::CPAN::Meta::HAVE_UTF8();
+       unless ( Parse::CPAN::Meta::HAVE_UTF8() ) {
+               skip("no utf8 support", 1 );
+       }
+       eval { utf8::is_utf8('') };
+       if ( $@ ) {
+               skip("no is_utf8 to test with until 5.8.1", 1);
+       }
        ok( utf8::is_utf8($yaml[0]->{author}), "utf8 decoded" );
 }