Integrate change #11408 from macperl.
authorJarkko Hietaniemi <jhi@iki.fi>
Sat, 21 Jul 2001 23:07:43 +0000 (23:07 +0000)
committerJarkko Hietaniemi <jhi@iki.fi>
Sat, 21 Jul 2001 23:07:43 +0000 (23:07 +0000)
p4raw-link: @11408 on //depot/maint-5.6/macperl: dbb4888cf530f5a0f1689f26b30cde9e6c537f71

p4raw-id: //depot/perl@11433
p4raw-integrated: from //depot/maint-5.6/macperl@11432 'merge in'
README.macos (@11199..) pod/perlport.pod (@11263..)

README.macos
pod/perlport.pod

index a15cb61..240d203 100644 (file)
@@ -22,7 +22,7 @@ pieces. Support for Mac OS is now in the perl core, and MacPerl will be
 able to, in the future, keep in closer sync with regular perl releases.
 
 At this time, though, it is very buggy, and is under development.  An
-alpha release is coming very soon.
+alpha release is available, with work progressing toward a beta.
 
 To build perl for Mac OS (as an MPW tool), you will need the addition
 of the "macos" subdirectory, distributed separately.  It includes extra
@@ -33,10 +33,13 @@ To build the MacPerl application, you will also need the "macperl"
 directory, which includes the source files for creating the
 application itself.
 
-All of this is also available from the SourceForge site, via
-HTTP, FTP, and anonymous CVS.
+All of this is available from the development site, via
+HTTP and anonymous CVS.
 
-       http://macperl.sourceforge.net/
+       http://dev.macperl.org/
+
+The source is also in the main perl repository in the maint-5.6/macperl
+branch.
 
 You will also need compilers and libraries, all of them freely
 available.  These are linked to from the SourceForge site. Go that site
@@ -53,4 +56,4 @@ Nandor E<lt>pudge@pobox.comE<gt>.
 
 =head1 DATE
 
-Last modified 2001.04.05.
+Last modified 2001.07.19.
index 6496230..73d8d86 100644 (file)
@@ -795,15 +795,15 @@ Also see:
 
 =item *
 
-The MacPerl Pages, http://www.macperl.com/ .
+MacPerl Development, http://dev.macperl.org/ .
 
 =item *
 
-The MacPerl mailing lists, http://www.macperl.org/ .
+The MacPerl Pages, http://www.macperl.com/ .
 
 =item *
 
-MacPerl Module Porters, http://pudge.net/mmp/ .
+The MacPerl mailing lists, http://lists.perl.org/ .
 
 =back
 
@@ -1535,9 +1535,6 @@ Not implemented. (S<Mac OS>, Plan9)
 
 =item glob
 
-Globbing built-in, but only C<*> and C<?> metacharacters are supported.
-(S<Mac OS>)
-
 This operator is implemented via the File::Glob extension on most
 platforms.  See L<File::Glob> for portability information.
 
@@ -1552,8 +1549,10 @@ Available only for socket handles. (S<RISC OS>)
 
 =item kill SIGNAL, LIST
 
-Not implemented, hence not useful for taint checking. (S<Mac OS>,
-S<RISC OS>)
+C<kill(0, LIST)> is implemented for the sake of taint checking;
+use with other signals is unimplemented. (S<Mac OS>)
+
+Not implemented, hence not useful for taint checking. (S<RISC OS>)
 
 C<kill()> doesn't have the semantics of C<raise()>, i.e. it doesn't send
 a signal to the identified process like it does on Unix platforms.
@@ -1606,8 +1605,6 @@ platforms.  (SunOS, Solaris, HP-UX)
 
 =item pipe READHANDLE,WRITEHANDLE
 
-Not implemented. (S<Mac OS>)
-
 Very limited functionality. (MiNT)
 
 =item readlink EXPR
@@ -1669,7 +1666,7 @@ be implemented even in UNIX platforms.
 
 =item socketpair SOCKET1,SOCKET2,DOMAIN,TYPE,PROTOCOL
 
-Not implemented. (S<Mac OS>, Win32, VMS, S<RISC OS>, VOS, VM/ESA)
+Not implemented. (Win32, VMS, S<RISC OS>, VOS, VM/ESA)
 
 =item stat FILEHANDLE
 
@@ -1921,8 +1918,8 @@ distribution available at http://www.perl.com/CPAN/src/index.html
         1) in DOS mode either the DOS or OS/2 ports can be used
         2) Mac OS Classic (pre-X) is almost 5.6.1-ready; building from
           the source does work with 5.6.1, but additional MacOS specific
-           source code is needed for a complete build.  Contact the mailing
-           list macperl-porters@macperl.org for more information.
+           source code is needed for a complete build.  See the web
+           site http://dev.macperl.org/ for more information.
         3) compilers: Borland, Cygwin, Mingw32 EGCS/GCC, VC++
 
 The following platforms worked for the previous releases (5.6.0 and 5.7.0),