B::OP::terse will go away in Perl 5.28.
authorAbigail <abigail@abigail.be>
Thu, 24 Nov 2016 14:35:43 +0000 (15:35 +0100)
committerAbigail <abigail@abigail.be>
Mon, 16 Jan 2017 18:18:15 +0000 (19:18 +0100)
Adjusted the deprecation message, and bumped the version of B::Terse.

ext/B/B/Terse.pm
pod/perldeprecation.pod

index 8e551c5..1749f32 100644 (file)
@@ -1,6 +1,6 @@
 package B::Terse;
 
-our $VERSION = '1.06';
+our $VERSION = '1.07';
 
 use strict;
 use B qw(class @specialsv_name);
@@ -33,7 +33,7 @@ sub indent {
 # Don't use this, at least on OPs in subroutines: it has no way of
 # getting to the pad, and will give wrong answers or crash.
 sub B::OP::terse {
-    carp "B::OP::terse is deprecated; use B::Concise instead";
+    carp "B::OP::terse is deprecated and will go away in Perl 5.28; use B::Concise instead";
     B::Concise::b_terse(@_);
 }
 
index 90861de..074ffd9 100644 (file)
@@ -187,6 +187,13 @@ of the variable happened in Perl 5.25.3.
 Setting this variable will become a fatal error in Perl 5.28.
 
 
+=head3 C<< B::OP::terse >>
+
+This method, which just calls C<< B::Concise::b_terse >>, has been
+deprecated, and will disappear in Perl 5.28. Please use 
+C<< B::Concise >> instead.
+
+
 
 =head3 Use of inherited AUTOLOAD for non-method %s() is deprecated