miniperl can no longer run installperl.
authorCraig A. Berry <craigberry@mac.com>
Thu, 5 Jan 2012 01:07:59 +0000 (19:07 -0600)
committerCraig A. Berry <craigberry@mac.com>
Thu, 5 Jan 2012 01:07:59 +0000 (19:07 -0600)
installperl now requires Porting/pod_lib.pl, which uses Digest::MD5,
which means we need something that can do dynamic loading (or has
extensions statically linked in).  But it doesn't really matter
because presumably we wouldn't be installing Perl if we hadn't
built it, so use the perl we've built rather than miniperl.

vms/descrip_mms.template

index c90bc45..8c11807 100644 (file)
@@ -656,10 +656,11 @@ minitest : $(MINITEST_EXE) [.lib.VMS]Filespec.pm unidatafiles.ts
 
 # install ought not need a source, but it doesn't work if one's not
 # there. Go figure...
-install : $(MINIPERL_EXE)
+install : $(PERL_EXE)
        @ @perl_setup.com
        If F$TrnLnm("Sys") .nes. "" Then Deass SYS
-       $(MINIPERL) installperl
+       @ define/user_mode $(DBG)PERLSHR SYS$DISK:[]$(DBG)perlshr$(E)
+       $(PERL) installperl
 
 archify : all
        @ Write Sys$Output "Moving files to architecture-specific locations for $(ARCHNAME)"