Deprecate importenv.pl with a warning
authorSteffen Mueller <smueller@cpan.org>
Wed, 2 Sep 2009 18:14:52 +0000 (20:14 +0200)
committerSteffen Mueller <smueller@cpan.org>
Wed, 2 Sep 2009 18:14:52 +0000 (20:14 +0200)
lib/importenv.pl

index 0401127..75274c2 100644 (file)
@@ -1,3 +1,12 @@
+# This library is no longer being maintained, and is included for backward
+# compatibility with Perl 4 programs which may require it.
+# This legacy library is deprecated and will be removed in a future
+# release of perl.
+
+warn( "The 'importenv.pl' legacy library is deprecated and will be"
+      . " removed in the next major release of perl. Please use the"
+      . " Env::Export module (or similar) from CPAN instead." );
+
 ;# This file, when interpreted, pulls the environment into normal variables.
 ;# Usage:
 ;#     require 'importenv.pl';