autouse: update tests to match new v1.11 CPAN release
authorRicardo Signes <rjbs@cpan.org>
Sun, 13 Mar 2016 22:47:18 +0000 (18:47 -0400)
committerRicardo Signes <rjbs@cpan.org>
Sun, 13 Mar 2016 22:47:18 +0000 (18:47 -0400)
dist/autouse/lib/autouse.pm
dist/autouse/t/autouse.t

index 7061b7b..2dd8c1d 100644 (file)
@@ -3,7 +3,7 @@ package autouse;
 #use strict;           # debugging only
 use 5.006;             # use warnings
 
-$autouse::VERSION = '1.10';
+$autouse::VERSION = '1.11';
 
 $autouse::DEBUG ||= 0;
 
index 74cad59..a790403 100644 (file)
@@ -96,8 +96,7 @@ SKIP: {
        'no redefinition warning when clobbering autouse stub via *a=\&b';
 }
 SKIP: {
-    skip "Fails from 5.10 to 5.15.5 (perl bug)", 1
-       if $] < 5.0150051 and $] > 5.0099;
+    skip "Fails in 5.15.5 and below (perl bug)", 1 if $] < 5.0150051;
     use Config;
     skip "no B", 1 unless $Config{extensions} =~ /\bB\b/;
     use warnings; local $^W = 1; no warnings 'once';