Upgrade perlfaq to 5.0150041
authorSteve Hay <steve.m.hay@googlemail.com>
Wed, 15 Aug 2012 23:12:09 +0000 (00:12 +0100)
committerSteve Hay <steve.m.hay@googlemail.com>
Wed, 15 Aug 2012 23:12:09 +0000 (00:12 +0100)
Porting/Maintainers.pl
cpan/perlfaq/lib/perlfaq.pm
cpan/perlfaq/lib/perlfaq3.pod
cpan/perlfaq/lib/perlfaq4.pod
cpan/perlfaq/lib/perlfaq5.pod
pod/perldelta.pod

index 9109dfd..6181588 100755 (executable)
@@ -768,7 +768,7 @@ use File::Glob qw(:case);
 
     'perlfaq' => {
         'MAINTAINER'   => 'perlfaq',
 
     'perlfaq' => {
         'MAINTAINER'   => 'perlfaq',
-        'DISTRIBUTION' => 'LLAP/perlfaq-5.0150040.tar.gz',
+        'DISTRIBUTION' => 'LLAP/perlfaq-5.0150041.tar.gz',
         'FILES'        => q[cpan/perlfaq],
         'EXCLUDED'     => [
             qw( t/release-pod-syntax.t
         'FILES'        => q[cpan/perlfaq],
         'EXCLUDED'     => [
             qw( t/release-pod-syntax.t
index 163c599..bbd176c 100644 (file)
@@ -1,6 +1,6 @@
 package perlfaq;
 {
 package perlfaq;
 {
-  $perlfaq::VERSION = '5.0150040';
+  $perlfaq::VERSION = '5.0150041';
 }
 
 0; # not is it supposed to be loaded
 }
 
 0; # not is it supposed to be loaded
index 9e9ae8d..8f90c60 100644 (file)
@@ -366,6 +366,13 @@ Perl Editor by EngInSite is a complete integrated development
 environment (IDE) for creating, testing, and  debugging  Perl scripts;
 the tool runs on Windows 9x/NT/2000/XP or later.
 
 environment (IDE) for creating, testing, and  debugging  Perl scripts;
 the tool runs on Windows 9x/NT/2000/XP or later.
 
+=item Kephra
+
+L<http://kephra.sf.net>
+
+GUI Editor written in Perl using wxWidgets and Scintilla with lots of smaller features.
+Aims for an UI based on Perls principles like TIMTWTDI and "easy thinkd should be ..".
+
 =item Komodo
 
 L<http://www.ActiveState.com/Products/Komodo/>
 =item Komodo
 
 L<http://www.ActiveState.com/Products/Komodo/>
index e5de153..8378ba7 100644 (file)
@@ -1266,8 +1266,8 @@ for list operations, so list operations also work on arrays:
     wash_animals( qw( dog cat bird ) );
     wash_animals( @animals );
 
     wash_animals( qw( dog cat bird ) );
     wash_animals( @animals );
 
-Array operations, which change the scalars, rearranges them, or adds
-or subtracts some scalars, only work on arrays. These can't work on a
+Array operations, which change the scalars, rearrange them, or add
+or subtract some scalars, only work on arrays. These can't work on a
 list, which is fixed. Array operations include C<shift>, C<unshift>,
 C<push>, C<pop>, and C<splice>.
 
 list, which is fixed. Array operations include C<shift>, C<unshift>,
 C<push>, C<pop>, and C<splice>.
 
index d03ca9f..c8cb64e 100644 (file)
@@ -194,11 +194,11 @@ you can fit the whole thing in memory!):
     open my $in,  '<',  $file      or die "Can't read old file: $!"
     open my $out, '>', "$file.new" or die "Can't write new file: $!";
 
     open my $in,  '<',  $file      or die "Can't read old file: $!"
     open my $out, '>', "$file.new" or die "Can't write new file: $!";
 
-    my @lines = do { local $/; <$in> }; # slurp!
+    my $content = do { local $/; <$in> }; # slurp!
 
         # do your magic here
 
 
         # do your magic here
 
-    print $out @lines;
+    print $out $content;
 
 Modules such as L<File::Slurp> and L<Tie::File> can help with that
 too. If you can, however, avoid reading the entire file at once. Perl
 
 Modules such as L<File::Slurp> and L<Tie::File> can help with that
 too. If you can, however, avoid reading the entire file at once. Perl
index 3765239..b5ef8d7 100644 (file)
@@ -200,6 +200,11 @@ modify behaviour.
 
 =item *
 
 
 =item *
 
+L<perlfaq> has been upgraded from version 5.0150040 to 5.0150041.  This
+contains a couple of minor corrections and lists one new editor.
+
+=item *
+
 L<Pod::Simple> has been upgraded from version 3.20 to 3.23.  Numerous
 improvements have been made, mostly to Pod::Simple::XHTML, which also has a
 compatibility change: the C<codes_in_verbatim> option is now disabled by
 L<Pod::Simple> has been upgraded from version 3.20 to 3.23.  Numerous
 improvements have been made, mostly to Pod::Simple::XHTML, which also has a
 compatibility change: the C<codes_in_verbatim> option is now disabled by