Deprecate pwd.pl with a warning
authorSteffen Mueller <smueller@cpan.org>
Wed, 2 Sep 2009 21:04:03 +0000 (23:04 +0200)
committerSteffen Mueller <smueller@cpan.org>
Wed, 2 Sep 2009 21:04:03 +0000 (23:04 +0200)
lib/pwd.pl

index 6b429eb..1eb1ce7 100644 (file)
@@ -3,12 +3,18 @@
 #
 # This library is no longer being maintained, and is included for backward
 # compatibility with Perl 4 programs which may require it.
+# This legacy library is deprecated and will be removed in a future
+# release of perl.
 #
 # In particular, this should not be used as an example of modern Perl
 # programming techniques.
 #
 # Suggested alternative: Cwd
-#
+
+warn( "The 'pwd.pl' legacy library is deprecated and will be"
+      . " removed in the next major release of perl. Please use the"
+      . " Cwd module instead." );
+
 ;# $RCSfile: pwd.pl,v $$Revision: 4.1 $$Date: 92/08/07 18:24:11 $
 ;#
 ;# $Log:       pwd.pl,v $