autodoc.pl needs -Ilib. I had been testing with a perl that was also installed.
authorNicholas Clark <nick@ccl4.org>
Sat, 18 Apr 2009 17:36:59 +0000 (18:36 +0100)
committerNicholas Clark <nick@ccl4.org>
Sat, 18 Apr 2009 17:36:59 +0000 (18:36 +0100)
Makefile.SH
vms/descrip_mms.template

index 156d275..063602c 100644 (file)
@@ -972,7 +972,7 @@ uni.data: miniperl$(EXE_EXT) $(CONFIGPM) lib/unicore/mktables
        touch uni.data
 
 pod/perlapi.pod pod/perlintern.pod: miniperl$(EXE_EXT) autodoc.pl embed.fnc
-       $(RUN) ./miniperl$(EXE_EXT) autodoc.pl
+       $(RUN) ./miniperl$(EXE_EXT) -Ilib autodoc.pl
 
 extra.pods: miniperl$(EXE_EXT)
        -@test ! -f extra.pods || rm -f `cat extra.pods`
index 6730bcc..ade9c2f 100644 (file)
@@ -429,7 +429,7 @@ pod = $(pod0) $(pod1) $(pod2) $(pod3) $(pod4) $(pod5) $(pod6) $(pod7) $(pod8) $(
        Copy/NoConfirm/Log $(MMS$SOURCE) $(MMS$TARGET)
 
 [.pod]perlapi.pod [.pod]perlintern.pod : miniperl embed.fnc autodoc.pl
-       $(MINIPERL) autodoc.pl
+       $(MINIPERL) -"I[-.lib]" autodoc.pl
 
 perlpods : $(pod)
        @ $(NOOP)