feature.pm needs to cope with the version not being 5.10.0
authorNicholas Clark <nick@ccl4.org>
Wed, 19 Dec 2007 13:47:36 +0000 (13:47 +0000)
committerNicholas Clark <nick@ccl4.org>
Wed, 19 Dec 2007 13:47:36 +0000 (13:47 +0000)
p4raw-id: //depot/perl@32645

lib/feature.pm

index 5990b72..a62352b 100644 (file)
@@ -1,6 +1,6 @@
 package feature;
 
-our $VERSION = '1.11';
+our $VERSION = '1.12';
 
 # (feature name) => (internal name, used in %^H)
 my %feature = (
@@ -11,11 +11,13 @@ my %feature = (
 
 my %feature_bundle = (
     "5.10.0" => [qw(switch say state)],
+    "5.11.0" => [qw(switch say state)],
 );
 
 # latest version here
-$feature_bundle{"5.10"} = $feature_bundle{sprintf("%vd",$^V)};
+$feature_bundle{"5.11"} = $feature_bundle{sprintf("%vd",$^V)};
 
+$feature_bundle{"5.10"} = $feature_bundle{"5.10.0"};
 $feature_bundle{"5.9.5"} = $feature_bundle{"5.10.0"};
 
 # TODO: