hints/freebsd.sh update (don't use -lmalloc)
authorSlaven Rezic <eserte@cs.tu-berlin.de>
Mon, 31 Mar 1997 14:17:42 +0000 (16:17 +0200)
committerChip Salzenberg <chip@atlantic.net>
Tue, 25 Mar 1997 19:04:34 +0000 (07:04 +1200)
Here's an update for hints/freebsd.sh. Configure should not try to use
-lmalloc, since it's very likely an old malloc from the compatibility
package compat1.x.

p5p-msgid: 199703311417.QAA04162@cabulja.herceg.de

hints/freebsd.sh

index 4b7653a..7ec8751 100644 (file)
@@ -68,9 +68,11 @@ case "$osvers" in
        ;;
 #
 # 2.2 and above have phkmalloc(3).
+# don't use -lmalloc (maybe there's an old one from 1.1.5.1 floating around)
 2.2*)
        usevfork='true'
        usemymalloc='n'
+       libswanted=`echo $libswanted | sed 's/ malloc / /'`
        d_dosuid='define'
        d_setregid='define'
        d_setreuid='define'
@@ -81,6 +83,7 @@ case "$osvers" in
 # Guesses at what will be needed after 2.2
 *)     usevfork='true'
        usemymalloc='n'
+       libswanted=`echo $libswanted | sed 's/ malloc / /'`
        ;;
 esac