Re: binary compatibility
authorAndy Dougherty <doughera@lafayette.edu>
Tue, 23 Apr 2002 16:21:26 +0000 (12:21 -0400)
committerJarkko Hietaniemi <jhi@iki.fi>
Tue, 23 Apr 2002 23:45:41 +0000 (23:45 +0000)
Message-ID: <Pine.SOL.4.10.10204231614020.754-100000@maxwell.phys.lafayette.edu>

p4raw-id: //depot/perl@16121

INSTALL
patchlevel.h

diff --git a/INSTALL b/INSTALL
index 1d27d65..63026ce 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -2096,6 +2096,9 @@ approach.
 
 =head1 Coexistence with earlier versions of perl5
 
+Perl 5.8 is not binary compatible with earlier versions of Perl.
+In other words, you have to recompile your XS modules.
+
 In general, you can usually safely upgrade from one version of Perl (e.g.
 5.004_04) to another similar version (e.g. 5.004_05) without re-compiling
 all of your add-on extensions.  You can also safely leave the old version
index 1138ddb..43f732c 100644 (file)
@@ -30,8 +30,8 @@
    to include in @INC.  See INSTALL for how this works.
 */
 #define PERL_API_REVISION      5       /* Adjust manually as needed.  */
-#define PERL_API_VERSION       5       /* Adjust manually as needed.  */
-#define PERL_API_SUBVERSION    0       /* Adjust manually as needed.  */
+#define PERL_API_VERSION       7       /* Adjust manually as needed.  */
+#define PERL_API_SUBVERSION    3       /* Adjust manually as needed.  */
 /*
    XXX Note:  The selection of non-default Configure options, such
    as -Duselonglong may invalidate these settings.  Currently, Configure