Update CPANPLUS to 0.8601
authorJos I. Boumans <jos@dwim.org>
Tue, 28 Apr 2009 15:05:31 +0000 (17:05 +0200)
committerVincent Pit <perl@profvince.com>
Tue, 28 Apr 2009 15:05:31 +0000 (17:05 +0200)
lib/CPANPLUS.pm
lib/CPANPLUS/Internals.pm
lib/CPANPLUS/Module.pm
lib/CPANPLUS/Selfupdate.pm
lib/CPANPLUS/Shell/Default.pm
lib/CPANPLUS/t/21_CPANPLUS-Dist-No-Build.t

index c1d0377..a4b9569 100644 (file)
@@ -13,7 +13,7 @@ BEGIN {
     use vars        qw( @EXPORT @ISA $VERSION );
     @EXPORT     =   qw( shell fetch get install );
     @ISA        =   qw( Exporter );
-    $VERSION = "0.86";     #have to hardcode or cpan.org gets unhappy
+    $VERSION = "0.8601";     #have to hardcode or cpan.org gets unhappy
 }
 
 ### purely for backward compatibility, so we can call it from the commandline:
index 33628ef..f5d961b 100644 (file)
@@ -42,7 +42,7 @@ use vars qw[@ISA $VERSION];
             CPANPLUS::Internals::Report
         ];
 
-$VERSION = "0.86";
+$VERSION = "0.8601";
 
 =pod
 
index 67b78b8..b5602e1 100644 (file)
@@ -676,15 +676,19 @@ sub get_installer_type {
     }
 
     ### ok, so it's a 'build' installer, but you don't /have/ module build
-    if( $type eq INSTALLER_BUILD and 
+    ### XXX duplicated from CPANPLUS::Selfupdate. fix somehow?
+    if( $type eq INSTALLER_BUILD and (
         not CPANPLUS::Dist->has_dist_type( INSTALLER_BUILD )
-    ) {
+        or not $cb->module_tree( INSTALLER_BUILD )
+                    ->is_uptodate( version => '0.24' )
+    ) ) {
     
         ### XXX this is for recording purposes only. We *have* to install
         ### these before even creating a dist object, or we'll get an error
         ### saying 'no such dist type';
+        ### XXX duplicated from CPANPLUS::Selfupdate. fix somehow?
         my $href = $self->status->configure_requires || {};
-        my $deps = { INSTALLER_BUILD, 0, %$href };
+        my $deps = { INSTALLER_BUILD, '0.24', %$href };
         
         $self->status->configure_requires( $deps );
         
index b8b40ed..1346de8 100644 (file)
@@ -79,7 +79,7 @@ CPANPLUS::Selfupdate
                     my $cb = shift;
                     $cb->configure_object->get_conf('prefer_makefile') 
                         ? { }
-                        : { 'CPANPLUS::Dist::Build' => '0.04'  };
+                        : { 'CPANPLUS::Dist::Build' => '0.24'  };
                 },
                 sub { return 1 },   # always enabled
             ],            
index 8c4f810..8e059f7 100644 (file)
@@ -26,7 +26,7 @@ local $Data::Dumper::Indent     = 1; # for dumpering from !
 BEGIN {
     use vars        qw[ $VERSION @ISA ];
     @ISA        =   qw[ CPANPLUS::Shell::_Base::ReadLine ];
-    $VERSION = "0.86";
+    $VERSION = "0.8601";
 }
 
 load CPANPLUS::Shell;
index 6ac77f6..55007ba 100644 (file)
@@ -49,6 +49,8 @@ ok( not grep { $_ eq $Inst } CPANPLUS::Dist->dist_types,
     ok( scalar(keys(%$href)),   "   Dependencies recorded" );
     
     ok( defined $href->{$Inst}, "       Dependency on $Inst" );
+    cmp_ok( $href->{$Inst}, '>', 0,
+                                "           Minimum version: $href->{$Inst}" );
 
     my $err = CPANPLUS::Error->stack_as_string;
     like( $err, qr/$Inst/,      "   Message mentions $Inst" );