don't distribute version::vpp/EUMM::version::vpp
authorDaniel Dragan <bulk88@hotmail.com>
Sun, 25 Oct 2015 22:53:13 +0000 (18:53 -0400)
committerTony Cook <tony@develop-help.com>
Tue, 27 Oct 2015 23:34:34 +0000 (10:34 +1100)
commitce9582afa265ba88092dee4d095faf7450deb501
tree9efedd23b40419049fb33e45df79067cc6178ab4
parent6504068eb895d4fb6161ddbb0249e59c19afa707
don't distribute version::vpp/EUMM::version::vpp

version::vpp is not part of the public API of version::, the core
cpan/version/lib/version.pm is not capable of using it unlike the
version.pm on cpan, and the Makefile.PL from cpan version:: that picks
between vpp and vxs isn't in core either. The xsubs behind core version.pm
are permanently baked in universal.c, they arent "static XS" or
"dynamic (shared lib) XS", and no XSLoader/DynaLoader is used. vpp.pm is
therefore useless in blead distributed version:: since vpp.pm is only
useful on very old perls. In blead, vpp only existed for the purpose of
making 00impl-pp.t pass, yet takes up space in the perl tarball, and was
installed into the final install location, so remove vpp.pm to save space
since it is unusable. vpp.pm and the rest of version is developed on
cpan, not in core, and vpp.pm is sort of a devel tool and sanity check and
therefore an author test, and core doesn't include author tests like
pod-coverage.t so that is one other reason it is being removed.

Also remove EUMM's vpp.pm, first it isn't miniperl compatible, and it also
is a copy more or less of version::vpp, and blead perl comes with
version.pm, since it is blead perl and not an old perl. If there is an
accident/error/bad behaviour EUMM::vpp.pm can get loaded
( http://www.nntp.perl.org/group/perl.perl5.porters/2015/10/msg232039.html
), but it is an error for it to ever be loaded. Prevent "silent failure"
by deleteing EUMM::vpp.pm, this way the failure will be an obvious
can't find EUMM::vpp.pm instead of subtle differences between the XS and
PP version implementations, or the not miniperl compatible failure.
Although ExtUtils::MakeMaker::version::regex.pm could be deleted for
the same reasons as EUMM::vpp.pm, I am leaving it in for now until the
EUMM patch in "version PP is not PP" goes through review, but still dont
install it, blead comes with the official version::regex.pm

version::vpp.pm is 22KB
00impl-pp.t is 0.5KB
ExtUtils::MakeMaker::version::vpp.pm is 23KB
ExtUtils::MakeMaker::version::regex.pm is 5KB

The 3 .pm files were being installed into the final installed perl location
where they are useless on blead perl. Some people complain perl core is
too big/bloated (redhat perl), removing 50KB and 3 files from final
location, and 45.5KB and 3 files from the tarball helps to trim the
core.
MANIFEST
Porting/Maintainers.pl
cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker/version/vpp.pm [deleted file]
cpan/version/lib/version/vpp.pm [deleted file]
cpan/version/t/00impl-pp.t [deleted file]
installperl