Require v7.3-2 or later for VMS builds.
authorCraig A. Berry <craigberry@mac.com>
Sun, 28 Jun 2015 17:37:27 +0000 (12:37 -0500)
committerCraig A. Berry <craigberry@mac.com>
Sun, 28 Jun 2015 17:37:27 +0000 (12:37 -0500)
commit054a3baf7ca16fe022e9a5fd56c158300d5c44f5
treef2ec729be1f37bf46bef16df5b0c7dc3e78f579a
parent2ad792cd4e9684519736fe03fd28a706b71ceda3
Require v7.3-2 or later for VMS builds.

OpenVMS v7.3-2 was released in 2003.  Regular support ended in 2006
and even prior version support will be ending in 2015, so this
seems like a pretty generous minimum for future Perl versions.

A side of effect of this is that OpenVMS VAX will no longer be
supported.  The terminal software release for VAX was v7.3 in 2001
with support ending in 2012.  VAX was a truly great architecture
in the 1970s, 1980s, and 1990s, but it's just missing too many of
the things expected in architectures, file systems and C run-times
of the current century.

De-supporting this older stuff allows quite a bit of code removal
and simplification, hopefully easing the maintenance burden a bit.
configure.com
vms/descrip_mms.template
vms/gen_shrfls.pl
vms/vms.c
vms/vmsish.h