Fix for pod2man() in ExtUtils::Command::MM to work with
[perl.git] / lib / ExtUtils / Command / MM.pm
index 046fb8b..774e1b2 100644 (file)
@@ -9,7 +9,7 @@ use vars qw($VERSION @ISA @EXPORT);
 
 @EXPORT  = qw(test_harness pod2man perllocal_install uninstall 
               warn_if_old_packlist);
-$VERSION = '0.05';
+$VERSION = '0.05_01';
 
 my $Is_VMS = $^O eq 'VMS';
 
@@ -117,8 +117,6 @@ sub pod2man {
     # compatibility.
     delete $options{lax};
 
-    my $parser = Pod::Man->new(%options);
-
     do {{  # so 'next' works
         my ($pod, $man) = splice(@ARGV, 0, 2);
 
@@ -128,6 +126,7 @@ sub pod2man {
 
         print "Manifying $man\n";
 
+        my $parser = Pod::Man->new(%options);
         $parser->parse_from_file($pod, $man)
           or do { warn("Could not install $man\n");  next };