Ensure regen.pl and the scripts that it calls can be run by older perls.
[perl.git] / opcode.pl
index e90c929..8879dd2 100755 (executable)
--- a/opcode.pl
+++ b/opcode.pl
@@ -109,7 +109,9 @@ my @raw_alias = (
                );
 
 while (my ($func, $names) = splice @raw_alias, 0, 2) {
-    $alias{$_} = $func for @$names;
+    foreach (@$names) {
+       $alias{$_} = $func;
+    }
 }
 
 # Emit defines.