[ID 20020407.002] Bug (?) and patch for DProf
[perl.git] / patchlevel.h
1 /*    patchlevel.h
2  *
3  *    Copyright (c) 1997-2002, Larry Wall
4  *
5  *    You may distribute under the terms of either the GNU General Public
6  *    License or the Artistic License, as specified in the README file.
7  *
8  */
9
10 #ifndef __PATCHLEVEL_H_INCLUDED__
11
12 /* do not adjust the whitespace! Configure expects the numbers to be
13  * exactly on the third column */
14
15 #define PERL_REVISION   5               /* age */
16 #define PERL_VERSION    7               /* epoch */
17 #define PERL_SUBVERSION 3               /* generation */
18
19 /* The following numbers describe the earliest compatible version of
20    Perl ("compatibility" here being defined as sufficient binary/API
21    compatibility to run XS code built with the older version).
22    Normally this should not change across maintenance releases.
23
24    Note that this only refers to an out-of-the-box build.  Many non-default
25    options such as usemultiplicity tend to break binary compatibility
26    more often.
27
28    This is used by Configure et al to figure out 
29    PERL_INC_VERSION_LIST, which lists version libraries
30    to include in @INC.  See INSTALL for how this works.
31 */
32 #define PERL_API_REVISION       5       /* Adjust manually as needed.  */
33 #define PERL_API_VERSION        5       /* Adjust manually as needed.  */
34 #define PERL_API_SUBVERSION     0       /* Adjust manually as needed.  */
35 /*
36    XXX Note:  The selection of non-default Configure options, such
37    as -Duselonglong may invalidate these settings.  Currently, Configure
38    does not adequately test for this.   A.D.  Jan 13, 2000
39 */
40
41 #define __PATCHLEVEL_H_INCLUDED__
42 #endif
43
44 /*
45         local_patches -- list of locally applied less-than-subversion patches.
46         If you're distributing such a patch, please give it a name and a
47         one-line description, placed just before the last NULL in the array
48         below.  If your patch fixes a bug in the perlbug database, please
49         mention the bugid.  If your patch *IS* dependent on a prior patch,
50         please place your applied patch line after its dependencies. This
51         will help tracking of patch dependencies.
52
53         Please edit the hunk of diff which adds your patch to this list,
54         to remove context lines which would give patch problems.  For instance,
55         if the original context diff is
56            *** patchlevel.h.orig        <date here>
57            --- patchlevel.h     <date here>
58            *** 38,43 ***
59            --- 38,44 ---
60                 ,"FOO1235 - some patch"
61                 ,"BAR3141 - another patch"
62                 ,"BAZ2718 - and another patch"
63            +    ,"MINE001 - my new patch"
64                 ,NULL
65              };
66         
67         please change it to 
68            *** patchlevel.h.orig        <date here>
69            --- patchlevel.h     <date here>
70            *** 41,43 ***
71            --- 41,44 ---
72            +    ,"MINE001 - my new patch"
73              };
74         
75         (Note changes to line numbers as well as removal of context lines.)
76         This will prevent patch from choking if someone has previously
77         applied different patches than you.
78  */
79 #if !defined(PERL_PATCHLEVEL_H_IMPLICIT) && !defined(LOCAL_PATCH_COUNT)
80 static  char    *local_patches[] = {
81         NULL
82         ,"DEVEL15771"
83         ,NULL
84 };
85
86 /* Initial space prevents this variable from being inserted in config.sh  */
87 #  define       LOCAL_PATCH_COUNT       \
88         (sizeof(local_patches)/sizeof(local_patches[0])-2)
89
90 /* the old terms of reference, add them only when explicitly included */
91 #define PATCHLEVEL              PERL_VERSION
92 #undef  SUBVERSION              /* OS/390 has a SUBVERSION in a system header */
93 #define SUBVERSION              PERL_SUBVERSION
94 #endif