Update podlators to version 4.03
[perl.git] / cpan / podlators / t / style / minimum-version.t
1 #!/usr/bin/perl
2 #
3 # Check that too-new features of Perl are not being used.
4 #
5 # The canonical version of this file is maintained in the rra-c-util package,
6 # which can be found at <http://www.eyrie.org/~eagle/software/rra-c-util/>.
7 #
8 # Written by Russ Allbery <eagle@eyrie.org>
9 # Copyright 2013, 2014
10 #     The Board of Trustees of the Leland Stanford Junior University
11 #
12 # Permission is hereby granted, free of charge, to any person obtaining a
13 # copy of this software and associated documentation files (the "Software"),
14 # to deal in the Software without restriction, including without limitation
15 # the rights to use, copy, modify, merge, publish, distribute, sublicense,
16 # and/or sell copies of the Software, and to permit persons to whom the
17 # Software is furnished to do so, subject to the following conditions:
18 #
19 # The above copyright notice and this permission notice shall be included in
20 # all copies or substantial portions of the Software.
21 #
22 # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
23 # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
24 # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
25 # THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
26 # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
27 # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
28 # DEALINGS IN THE SOFTWARE.
29
30 use 5.006;
31 use strict;
32 use warnings;
33
34 use lib 't/lib';
35
36 use Test::More;
37 use Test::RRA qw(skip_unless_automated use_prereq);
38 use Test::RRA::Config qw($MINIMUM_VERSION);
39
40 # Skip for normal user installs since this doesn't affect functionality.
41 skip_unless_automated('Minimum version tests');
42
43 # Load prerequisite modules.
44 use_prereq('Test::MinimumVersion');
45
46 # Check all files in the Perl distribution.
47 all_minimum_version_ok($MINIMUM_VERSION);