Move libnet Net::* to the top level, to mirror the CPAN distribution.
[perl.git] / ext / IO-Compress / README
1
2                              IO-Compress
3
4                              Version 2.021
5
6                              30th August 2009
7
8        Copyright (c) 1995-2009 Paul Marquess. All rights reserved.
9           This program is free software; you can redistribute it
10            and/or modify it under the same terms as Perl itself.
11
12 DESCRIPTION
13 -----------
14
15 This distribution provides a Perl interface to allow reading and writing of
16 compressed data created with the zlib and bzip2 libraries.
17
18 IO-Compress supports reading and writing of bzip2, RFC 1950, RFC
19 1951, RFC 1952 (i.e. gzip) and zip files/buffers.
20
21 The following modules used to be distributed separately, but are now
22 included with the IO-Compress distribution.
23
24     Compress-Zlib
25     IO-Compress-Zlib
26     IO-Compress-Bzip2
27     IO-Compress-Base
28
29 PREREQUISITES
30 -------------
31
32 Before you can build IO-Compress you need to have the following
33 installed on your system:
34
35     * Perl 5.004 or better. 
36     * Compress::Raw::Zlib
37     * Compress::Raw::Bzip2
38
39 BUILDING THE MODULE
40 -------------------
41
42 Assuming you have met all the prerequisites, the module can now be built
43 using this sequence of commands:
44
45     perl Makefile.PL
46     make
47     make test
48
49 INSTALLATION
50 ------------
51
52 To install IO-Compress, run the command below:
53
54     make install
55
56 TROUBLESHOOTING
57 ---------------
58
59 FEEDBACK
60 --------
61
62 How to report a problem with IO-Compress.
63
64 To help me help you, I need all of the following information:
65
66  1. The Versions of everything relevant.
67     This includes:
68
69      a. The *complete* output from running this
70      
71             perl -V
72      
73         Do not edit the output in any way.
74         Note, I want you to run "perl -V" and NOT "perl -v".
75      
76         If your perl does not understand the "-V" option it is too
77         old. This module needs Perl version 5.004 or better.     
78
79      b. The version of IO-Compress you have. 
80         If you have successfully installed IO-Compress, this one-liner
81         will tell you:
82
83            perl -MIO::Compress::Gzip -e 'print qq[ver $IO::Compress::Gzip::VERSION\n]'
84
85         If you are  running windows use this
86
87            perl -MIO::Compress::Gzip -e "print qq[ver $IO::Compress::Gzip::VERSION\n]"
88
89         If you haven't installed IO-Compress then search IO::Compress::Gzip.pm
90         for a line like this:
91
92           $VERSION = "2.021" ;
93
94  2. If you are having problems building IO-Compress, send me a
95     complete log of what happened. Start by unpacking the IO-Compress
96     module into a fresh directory and keep a log of all the steps
97
98         [edit config.in, if necessary]
99         perl Makefile.PL
100         make
101         make test TEST_VERBOSE=1          
102
103 Paul Marquess <pmqs@cpan.org>