regex: Use BOUNDU regnodes
[perl.git] / symbian / sanity.pl
1 use strict;
2
3 if (exists $ENV{'!C:'}) {
4   print "You are running this under Cygwin, aren't you? (found '!C' in %ENV)\n";
5   print "Are you perhaps using Cygwin Perl? (\$^O is '$^O')\n" if $^O =~ /cygwin/;
6   print "I'm sorry but only cmd.exe with e.g. the ActivePerl will work.\n";
7   exit(1);
8 }
9
10 unless(# S60 2.x
11        $ENV{PATH} =~ m!\\program files\\common files\\symbian\\tools!i
12        ||
13        # S60 1.2
14        $ENV{PATH} =~ m!\\symbian\\6.1\\shared\\epoc32\\tools!i
15        ||
16        # S80
17        $ENV{PATH} =~ m!\\s80_.+?\\epoc32\\!i
18        ||
19        # UIQ
20        $ENV{PATH} =~ m!\\uiq_.+?\\epoc32\\!i
21        ) {
22     print "I do not think you have installed a Symbian SDK, your PATH is:\n$ENV{PATH}\n";
23     exit(1);
24 }
25
26 unless (-f "symbian/symbianish.h") {
27   print "You must run this in the top level directory.\n";
28   exit(1);
29 }
30
31 if ($] < 5.008) {
32   print "You must configure with Perl 5.8 or later.\n";
33   exit(1);
34 }
35
36 1;