344169aeccf57c0be12ddded19d06b3d04095f2d
[perl.git] / cpan / IO-Compress / Makefile.PL
1 #! perl -w
2
3 use strict ;
4 require 5.006 ;
5
6 $::VERSION = '2.068' ;
7
8 use private::MakeUtil;
9 use ExtUtils::MakeMaker 5.16 ;
10
11 UpDowngrade(getPerlFiles('MANIFEST'))
12     unless $ENV{PERL_CORE};
13
14 WriteMakefile( 
15     NAME         => 'IO::Compress',
16     VERSION_FROM => 'lib/IO/Compress/Base.pm',
17     'dist'       => { COMPRESS     => 'gzip', 
18                       TARFLAGS     => '-chvf',
19                       SUFFIX       => 'gz',
20                       DIST_DEFAULT => 'MyTrebleCheck tardist',
21                     },
22
23     (
24       $ENV{SKIP_FOR_CORE}
25         ? ()
26             : (PREREQ_PM   => { 'Compress::Raw::Bzip2' => $::VERSION,
27                                     'Compress::Raw::Zlib'   => $::VERSION,
28                                     'Scalar::Util'  => 0,
29                                     $] >= 5.005 && $] < 5.006   
30                                 ? ('File::BSDGlob' => 0) 
31                                 : () }
32               )
33     ),
34        
35     (
36     $] >= 5.005
37         ? (ABSTRACT => 'IO Interface to compressed data files/buffers',
38             AUTHOR  => 'Paul Marquess <pmqs@cpan.org>')
39         : ()
40     ),
41
42     INSTALLDIRS => ($] >= 5.009 && $] < 5.011 ? 'perl' : 'site'),
43
44     EXE_FILES => ['bin/zipdetails'],
45     
46     (
47     $] >= 5.009 && $] <= 5.011001 && ! $ENV{PERL_CORE}
48         ? (INSTALLPRIVLIB    => '$(INSTALLARCHLIB)')
49         : ()
50     ),
51
52     META_MERGE => {
53         no_index => {
54             directory => [ 't', 'private' ],
55         },
56     },    
57
58     ((ExtUtils::MakeMaker->VERSION() gt '6.30') ?
59         ('LICENSE'  => 'perl')         : ()),    
60
61 ) ;
62
63 # end of file Makefile.PL
64