Make Module::CoreList install into 'site' >= 5.012
[perl.git] / dist / Module-CoreList / Makefile.PL
1 use ExtUtils::MakeMaker;
2
3 push @extra, 'INSTALLDIRS' => 'perl' if $] >= 5.008009 and $] < 5.012;
4
5
6 WriteMakefile
7 (
8     'NAME' => 'Module::CoreList',
9     'VERSION_FROM' => 'lib/Module/CoreList.pm',
10     'ABSTRACT_FROM' => 'lib/Module/CoreList.pod',
11     'PREREQ_PM' => {
12         'Test::More' => '0',
13     },
14     'EXE_FILES' => [ _scripts() ],
15     'PL_FILES' => {},
16     LICENSE => 'perl',
17     @extra,
18 )
19 ;
20
21 sub _scripts {
22  my $scripts = 'corelist';
23  if ( $] >= 5.008009 and !$ENV{PERL_CORE} ) {
24    require Config;
25    my $version = sprintf("%vd",$^V);
26    if ( $Config::Config{versiononly} and
27       $Config::Config{startperl} =~ /\Q$version\E$/ ) {
28       require File::Copy;
29       File::Copy::copy( 'corelist', "corelist$version" );
30       $scripts = "corelist$version";
31     }
32  }
33  return $scripts;
34 }