GCC_DIAG_IGNORE() only with >= 4.6
authorDavid Mitchell <davem@iabyn.com>
Thu, 28 Nov 2013 20:13:50 +0000 (20:13 +0000)
committerDavid Mitchell <davem@iabyn.com>
Thu, 28 Nov 2013 20:13:50 +0000 (20:13 +0000)
The new GCC_DIAG_IGNORE() pragma I added a few commits ago was only
supposed to be enabled on gcc 4.6+; my code inadvertently did it on
4.2+

perl.h

index b73c1a7..2d98004 100644 (file)
--- a/perl.h
+++ b/perl.h
  */
 
 #if defined(__clang) || \
-       (defined( __GNUC__) && ((__GNUC__ * 100) + __GNUC_MINOR__) >= 402)
+       (defined( __GNUC__) && ((__GNUC__ * 100) + __GNUC_MINOR__) >= 406)
 #  define GCC_DIAG_DO_PRAGMA_(x) _Pragma (#x)
 
 #  define GCC_DIAG_IGNORE(x) _Pragma("GCC diagnostic push") \